tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From colin schaub <co...@lautverschiebung.org>
Subject Tomcat 3.x.x servlet mapping issue
Date Fri, 15 Dec 2000 00:33:30 GMT
I have successfully installed Tomcat 3.1.1 and 3.2.1, and have run into an
issue involving servlet mappings and query information within the request
object.

If I define servlets within the web.xml files, for ROOT or any webapp,
with a servlet mapping and url alias, the query string is lost, only when
using the apache-tomcat configuration.

If the servlets are un-mapped and accessed like
http://company.com/webapp/SnoopServlet, everything works just fine. If I
create a mapping to a servlet such as com.company.MySnoopServlet with a
servlet mapping of http://company.com/snoop, all query information is
lost and comes through as null.

The environment in question is
- Linux Mandrake 7.1
- RedHat Apache 1.3.12
- jdk 1.3 (or jdk 1.2.2 - I've tried it with both, same results).
- tomcat 3.1.1 or tomcat 3.2.1
- all tomcat code (tomcat + mod_jserv.so) downloaded 12. dec.

This is *only* the case however when using the tomcat mod_jserv.so
connector. If I run Tomcat stand-alone, the query information is
available for all servlet mappings.

Any thoughts? Is this a configuration issue or a Tomcat bug?

Thanks for any insight!

colin schaub



Mime
View raw message