tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Remijan" <remi...@dchain.com>
Subject RE: $20 bucks to the 1st person who actually solves my problem!!!
Date Fri, 08 Dec 2000 15:09:19 GMT
David,

This might be worth a shot.  in the page you want reloaded, try adding in
this
<head>
<META HTTP-EQUIV = "Pragma" CONTENT="no-cache">
</head>

this meta tag forces no cache of the page so it is suppose to be refreshed
from the server everytime.  Let me know if this help.

Mike


> -----Original Message-----
> From: Adress, David S. [mailto:David.S.Adress@pfizer.com]
> Sent: Friday, December 08, 2000 7:29 AM
> To: 'tomcat-user@jakarta.apache.org'; 'JRun-Talk'
> Subject: $20 bucks to the 1st person who actually solves my problem!!!
>
>
> I am on this for days and I can't figure out what I'm doing wrong. I will
> send $20 bucks to 1st person who actually solves my problem.
>
> I am using jsp page's to control the layout of my page and
> servlets to spit
> back
> table data or to do database transactions.
>
> I have a jsp page that displays a list of employees. The jsp page
> has an include statement to include the servlet to spit out the table.
> The jsp just handles the general look of the page and the servlet just
> spits out the table and table html tags. Next to each record I have an add
> and
> delete hyperlink. If someone clicks the add link it displays
> another page to
> add
> an employee and then the action servlet adds the record and then goes back
> to the jsp
> list page. If some one deletes a record it calls a servlet to delete and
> then the servlet redirects back to the jsp list page. But the list doesn't
> display the updated data without having me hit the refresh button in the
> browser.
>
> I tried using Tomcat and now am using Jrun and am still having the same
> problem.
>
> I've included all the proper meta tags in the jsp list page not
> to cache but
> it's not working. I've also tries doing it with reponse.setHeader but it
> doesn't work either.
>
> I've tried sending a random number param to the page
> ShowList?rnd=Randomnumber it still doesn't work.
>
>
>


Mime
View raw message