tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "G.Nagarajan" <gnagara...@dkf.de>
Subject RE: problem with non-English characters on Solaris
Date Tue, 12 Dec 2000 08:49:56 GMT
hi,
try setting the Locale to the language you are using in your servlet before
the request.getParameter(),
it works fine on windows for me.

Regards,
Nagaraj.
  -----Original Message-----
  From: Jyoti Bansal [mailto:jbansal@netlens.com]
  Sent: Monday, December 11, 2000 11:58 PM
  To: 'tomcat-user@jakarta.apache.org'
  Subject: problem with non-english characters on solaris


  Hi all,

  I am using some non-english characters in HTTP request POST data. When I
post it to the servlet and do a request.getParameter() in the servlet code,
I get all the non-English characters replaced by a '?'.

  This is happening when the Tomcat is running on Solaris. I have tried
using Tomcat with Apache and also Tomcat standalone.
  If I run the same servlet on Windows NT and use the same non-English
characters it works fine.

  Can you please suggest me what can be wrong?
  I am using internationalized version of JDK and have made sure that
i18n.jar is in classpath , if that could be a reason.

  Has anyone seen such a problem before?

  Thanks

  Jyoti K. Bansal
  Software Engineer
  NetLens Inc.


Mime
View raw message