tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nacho <na...@siapi.es>
Subject RE: Isapi_redirect.dll v3.2 will not load
Date Tue, 05 Dec 2000 09:23:26 GMT
It's working for me without problems, have you changed the name of the
dir that contains your working copy ? if yes you will need to change
things as appropiate in the config of isapi_redirect.dll, but nothing
more and and far diffrent from 3.1 to 3.2, please feel free to post all
the details ( reg excerpt, *.properties files etc ), to see if we can
help you ...

Saludos ,
Ignacio J. Ortega


> -----Mensaje original-----
> De: Desaulniers, Peter [mailto:Peter.Desaulniers@pahv.xerox.com]
> Enviado el: martes 5 de diciembre de 2000 1:56
> Para: tomcat-user@jakarta.apache.org
> Cc: Desaulniers, Peter
> Asunto: Isapi_redirect.dll v3.2 will not load
> 
> 
> Facts:
> 
> WinNT 4.0SP6a, IIS 4.0
> Tomcat 3.2
> JDK 1.3
> 
> I have successfully install, configured and ran Tomcat 3.1 
> (as stand-alone,
> then out of process, and finally in-process) following the 
> documentation
> closely. However, after removing 3.1 and installing 3.2, I am 
> unable to get
> the isapi_redirect.dll to load.  I have followed the exact 
> same steps as 3.1
> for the IIS How-To (for out of process) but the dll fails to load (red
> downward arrow).  Tomcat 3.2 as a stand-alone works fine.
> 
> Questions:
> 
> 1. When I unzipped 3.2, I noticed that all of the text files 
> in the conf
> directory have non-MS carriage returns (i.e. black boxes when 
> viewed with
> Notepad). The same files were fine in 3.1 when viewed with 
> Notepad.  Could
> the improper carriage returns cause problems with running 
> tomcat within IIS?
> 
> 2. Does the registry key version for the Jakarta Isapi 
> Redirector remain 1.0
> for 3.2 as it was for 3.1?
> 
> 3. Someone suggested that the isapi_redirect filter need be 
> added at the web
> server level and not the default web site level.  I had it at 
> the default
> web site level for 3.1 and it worked.  For 3.2, it does work at either
> level.  What is the real requirement for 3.2?
> 
> 4. tomcat 3.2 unzips to the jakarta-tomcat-3.2 directory.  
> Version 3.1 ran
> out of jakarta-tomcat.  I deleted jakarta-tomcat and replaced 
> it with the
> 3.2 tree. Does that matter?
> 
> 5. Regarding the out of process mode, do I need to edit any 
> of the conf
> files for 3.2?  I did not have to edit any for 3.1.  
> 
> 6. What else can I look at to determine why the redirector won't load?
> 
> This seems to be giving alot of people headaches.  It would 
> be nice if some
> who was successful could post their configuration procedure 
> (or a modified
> How To document).  I would be happy to but first I must join 
> those who have
> been successful.
> 
> -- Peter Desaulniers
> 

Mime
View raw message