tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yin Tse <y...@valicert.com>
Subject RE: Servlet init parameters problems
Date Wed, 13 Dec 2000 01:45:14 GMT
Thanks david, it works great. :-)

-----Original Message-----
From: David Mulligan [mailto:dmulligan@careclinix.com]
Sent: Tuesday, December 12, 2000 3:35 PM
To: 'tomcat-user@jakarta.apache.org'
Subject: RE: Servlet init parameters problems


You have to put ini-param tags around each parameter.  If you do this and
call the servlet as named in the servlet-name tag, as opposed to
servlet-class it should work.

Hope this helps.

-----Original Message-----
From: Yin Tse [mailto:yint@valicert.com]
Sent: Tuesday, December 12, 2000 6:18 PM
To: 'tomcat-user@jakarta.apache.org'
Subject: Servlet init parameters problems



Hi all,
I'm having some problems reading my init parameters.
I define the init parameters in the web.xml file like this :


   <servlet>
        <servlet-name>login</servlet-name>
        <servlet-class>LoginServlet</servlet-class>
        <init-param>

	    <param-name>login</param-name>
            <param-value>joe</param-value>	 

	    <param-name> password</param-name>
            <param-value>pass</param-value>	 

    		<param-name>driverName</param-name>
            <param-value>oracle.jdbc.driver.OracleDriver</param-value>

	    <param-name> connectionUrl</param-name>
            <param-value>jdbc:oracle:thin:@xena:1521:wbdb</param-value>	

	    <param-name>url</param-name>
            <param-value>www.whatever.com</param-value>

	    <param-name>Base_url</param-name>
            <param-value>http://intranet/whateber/</param-value>	

	    <param-name>Images_url</param-name>
            <param-value>http://intranet/whatever/images</param-value>	
	

	
	    
	    <param-name>Servlet_url</param-name>
            <param-value>/servlet/</param-value>

	   
	</init-param>
    </servlet>

These are defined in the LoginServlet, but the parameters are read in a
parent servlet called DBConnectionServlet,
but all the params are coming null except the last one which is servlet_url
here.If I change the order and put the login init param at the bottom,
that's the param which will be read and all others come up null. Does anyone
know why ? Thanks for the feedback.



Mime
View raw message