tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefán F. Stefánsson <>
Subject Differerences in Jakarta distributions (Was 3.2.1 build fails - any ideas?) Please comment
Date Fri, 15 Dec 2000 10:24:00 GMT
Thanks everybody!

I've managed to build it now.  The problem was kindof weird and the
"solution" (if I can call it a solution) was even weirder...  Like one
of you pointed out I had to do a "build clean".  After that everything
worked.  I found this rather weird since I deleted EVERYTHING in my
Jakarta folder!  I even deleted ant and rebuilt it but still this
problem occurred.  After the "build clean" though... everything worked.

So I feel very stupid now if that makes anybody feel any better ;o)

But nobody has answered my comment and so I post it again:

I think there is a really big need for cleaning up the way Jakarta
projects are distributed.  There are differences between projects and
even within projects (like the root directory for tomcat 3.2 suddenly
changed from "tomcat-3.2" to "tomcat-3.2-bX" I think that happened with
the beta 7) For example:

1) Tomcat and servletapi come in a zip file that includes the root
directory for that project... that is, "jakarta-tomcat-3.2-src" and
"jakarta-servletapi-3.2-src" were included in the zip file and the files
are ready to be unzipped into the <JAKARTA-HOME> directory on the user
machine (well... almost... more on that in point 2.).  However, when I
downloaded Ant 1.2 that project came in a zip file that was structured
in a different way, specifically, it didnt' include the project root
directory so I had to make the jakarta-ant directory myself and unzip
the files into that directory.

2) When I had unzipped all files into the <JAKARTA-HOME> directory I had
a structure that looked something like this:


I built ant and servletapi but when I tried building tomcat I found out
that it was trying to point to the servletapi.jar in a directory that
was supposed to be called jakarta-servletapi but not
jakarta-servletapi-3.2-src like my structure was then.

Kind regards,
	Stefan Freyr.

View raw message