tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Long <b...@longboys.net>
Subject Help Please with JSPs
Date Wed, 06 Dec 2000 20:52:21 GMT
*This message was transferred with a trial version of CommuniGate(tm) Pro*
Hi. I have a completely stock install of tomcat 3.2 and JDK 1.3 on
solaris 2.6

I reconfigured my startupscripts to find my classpath and what not.  I
start up the Tomcat server and don't get any wierd error messages.  I
checked the output of the tomcat.sh start command get my classpath is
okay.

The example servlets work okay. When i try to run a jsp from the
examples it fails with the following.

Error: 500

Location: /examples/jsp/num/numguess.jsp

Internal Servlet Error:

javax.servlet.ServletException: sun/tools/javac/Main
        at
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:399)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
        at
org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:404)

        at org.apache.tomcat.core.Handler.service(Handler.java:286)
        at
org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
        at
org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)

        at
org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
        at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:210)

        at
org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)

        at
org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)

        at java.lang.Thread.run(Thread.java:484)

Root cause:

java.lang.NoClassDefFoundError: sun/tools/javac/Main
        at
org.apache.jasper.compiler.SunJavaCompiler.compile(SunJavaCompiler.java:128)

        at
org.apache.jasper.compiler.Compiler.compile(Compiler.java:245)
        at
org.apache.jasper.servlet.JspServlet.doLoadJSP(JspServlet.java:462)
        at
org.apache.jasper.servlet.JasperLoader12.loadJSP(JasperLoader12.java:146)

        at
org.apache.jasper.servlet.JspServlet.loadJSP(JspServlet.java:433)
        at
org.apache.jasper.servlet.JspServlet$JspServletWrapper.loadIfNecessary(JspServlet.java:152)

        at
org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(JspServlet.java:164)

        at
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:318)

        at
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:391)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
        at
org.apache.tomcat.core.ServletWrapper.doService(ServletWrapper.java:404)

        at org.apache.tomcat.core.Handler.service(Handler.java:286)
        at
org.apache.tomcat.core.ServletWrapper.service(ServletWrapper.java:372)
        at
org.apache.tomcat.core.ContextManager.internalService(ContextManager.java:797)

        at
org.apache.tomcat.core.ContextManager.service(ContextManager.java:743)
        at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(HttpConnectionHandler.java:210)

        at
org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java:416)

        at
org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java:498)

        at java.lang.Thread.run(Thread.java:484)

in looking at an extract of the /java/lib/tools.jar, i see there is
definatly a sun/tools/javac/Main.class in the tools.jar.

anybody got any idea what i'm doing wrong??  i'm totally stumped here.

the only wierd thing i have going on is that my /java is a link, but
when i put my real home in there, it doesnt work either.

thanks

bill


Mime
View raw message