tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig W. Blake" <cr...@gtb.net>
Subject Re: Problem compiling mod_jk.so
Date Wed, 06 Dec 2000 16:47:52 GMT
It works now.  A bit strange cause the command you gave was the same I was using
(except for the BSD stuff since I'm on linux) with the exception of the
-I/usr/local/apache/include bit because the mod_jk documentation didn't mention
it.  I guess that made all the difference.  Thanks a bunch.  Actually, you can add
Sun's 1.3 JVM for linux to the list since that's what I'm on and it works fine
now.  Again, thanks alot.

Craig B.

AC wrote:

> This is the response I already posted to a tomcat-user with the same
> problem...... I thought the problem was only on FreeBsd!! Which is the os
> you use?
> ---------------------------------------------------
> I'm not sure where is the error in the makefile because I'm not a shell
> expert, but I solve the problem launching by myself  apxs.
> The location of the apxs is (in my configuration) /usr/local/sbin/ instead
> of  ${APACHE_HOME}/bin/
> After correcting this I launch the Makefile that compile the
> mod_jk.so  (make all). The script launch :
>
> /usr/local/sbin/apxs -c -I/usr/local/jdk1.1.8/include
> -I/usr/local/jdk1.1.8/include/freebsd -DFREEBSD -I/usr/local/apache/include
> -I../jk mod_jk.c
>
> As you can see it compiles only the mod_jk.c. The command you have to
> launch is:
>
> /usr/local/sbin/apxs -c -I/usr/local/jdk1.1.8/include
> -I/usr/local/jdk1.1.8/include/freebsd -DFREEBSD -I/usr/local/apache/include
> -I../jk mod_jk.c ../jk/*.c
>
> If you use a different jdk just yank the apxs command and add ../jk/*.c  at
> the end as I did.
>
> It works with all the jdk (1.1.8, 1.2 beta native and 1.2 linux)
>
> Hope this help
>
> andrea
> --------------------------------
>
> At 08.53 06/12/2000 -0500, you wrote:
> >Ok, I'll try this again..
> >
> >
> >Hello all,
> >
> >I have a problem someone may be able to help with.  I tried to compile
> >mod_jk.so
> >
> >seperate from my apache source, and after enabling it in got the error
> >about it
> >being a garbled module.  So then I tried to compile it with the apache source
> >tree
> >(as a previous post recommended, I think) and had configure enable it, which
> >worked
> >fine, but when I try to execute apache it fails with the following message:
> >
> >Syntax error on line 238 of /usr/local/apache/conf/httpd.conf:
> >Cannot load /usr/local/apache/libexec/mod_jk.so into server:
> >/usr/local/apache/libexec/mod_jk.so: undefined symbol: map_name_at
> >
> >It looks like this function is defined in jk_map.h, but I am unsure of how to
> >get
> >apache to see it.  Any suggestions?  About all I could think of was putting it
> >into
> >the apache include dir, but this did not work.  Thanks in advance for your
> >help.
> >
> >Craig B.


Mime
View raw message