tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Bussenschutt <D.Bussensch...@mailbox.gu.edu.au>
Subject Re: Strange redirect problems with non-existent /servlets/ JkMount
Date Wed, 20 Dec 2000 00:20:48 GMT
I don't know if it's related, but I had a similar problem with weird
persistence of things that shouldn't persist after a restart, and found
that clearing out the $TOMCAT_HOME/work folder solved this:

$TOMCAT_HOME/conf/tomcat.sh stop
rm -rf $TOMCAT_HOME/work/*
$TOMCAT_HOME/conf/tomcat.sh start

Anyone else have this sort of problem?

David.

P.S. I'm not a java programmer, or a tomcat developer, so I can't tell you
why it worked, but it did.


At 10:57 PM 12/19/00 +0100, you wrote:
>I have run into a strange little problem. I have a web application
>consisting of 40 servlets. In the servlet code a good deal of redirects are
>going on between the servlets. All redirects are pointed towards
>"/app01/servlet/servletx".
>The only apps that are configured except the /app01 are /example, /test and
>/admin.
>
>The problem is that some of the redirections that are supposed to go to
>'/app01/servlet/servletx/' go to '/servlets/servletx' instead. 
>
>I've checked all the code, and there are no references to /servlets/
>anywhere... So, I'm kind of stuck here...
>I used to have a '/servlets' JkMount directive in httpd.conf, but not
>anymore.... Nothing in server.xml or web.xml either... What's going on here?
>Where does that /servlets/ come from?
>
>Is it possible to turn on debugging of the redirectHandler? If so, where?
>
>
>Mvh / Regards
>
>Christopher Cato <ccato@rational.com>
>Rational Software Nordic AB / ECAT - Ericsson Corporate Account Team 
>
>

--------------------------------------------------------------------
David Bussenschutt          Email: D.Bussenschutt@mailbox.gu.edu.au
Senior Computing Support Officer & Systems Administrator/Programmer
Location: Griffith University. Information Technology Services
          Brisbane Qld. Aust.  (TEN bldg. rm 1.33) Ph: (07)38757079
--------------------------------------------------------------------

Mime
View raw message