tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kitching Simon <Simon.Kitch...@orange.ch>
Subject RE: Strange redirect problem...
Date Wed, 20 Dec 2000 10:51:19 GMT
Hi,

Is it possible to try tomcat stand-alone instead of behind
apache? That will eliminate half the possible sources of
the redirect problems..

> -----Original Message-----
> From:	Cato, Christopher [SMTP:ccato@rational.com]
> Sent:	Tuesday, December 19, 2000 10:32 PM
> To:	'tomcat-user@jakarta.apache.org'
> Subject:	Strange redirect problem...
> 
> Hello... I'm running TomCat 3.21 on RedHat Linux 6.2 with Apache 1.3.12 /
> mod_jk
> 
> I have run into a strange little problem. I have a web application
> consisting of 40 servlets. In the servlet code a good deal of redirects
> are
> going on between the servlets. All redirects are pointed towards
> "/app01/servlet/servletx".
> The only apps that are configured except the /app01 are /example, /test
> and
> /admin.
> 
> The problem is that some of the redirections that are supposed to go to
> '/app01/servlet/servletx/' go to '/servlets/servletx' instead. 
> 
> I've checked all the code, and there are no references to /servlets/
> anywhere... So, I'm kind of stuck here...
> I used to have a '/servlets' JkMount directive in httpd.conf, but not
> anymore.... Nothing in server.xml or web.xml either... What's going on
> here?
> Where does that /servlets/ come from?
> 
> Is it possible to turn on debugging of the redirectHandler? If so, where?
> 
> 
> Mvh / Regards
> 
> Christopher Cato <ccato@rational.com>
> Rational Software Nordic AB / ECAT - Ericsson Corporate Account Team 

Mime
View raw message