tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kitching Simon <Simon.Kitch...@orange.ch>
Subject RE: At Value must be quoted. Error
Date Mon, 18 Dec 2000 18:03:45 GMT
Hi Don,

It looks to me like the XML parser that tomcat uses to read the file is
objecting to something in the file. Minor typos are sometimes damn
hard to spot :-)

I suggest:
(a) 
try commenting out blocks of the server.xml file, and restarting.
of course, tomcat won't *run* properly with only half a config file, but
you should be able to see when the config file at least parses.
By the old divide-and-conquer method, you should be able to narrow
things down to the point you can spot the problem,
(b)
If you have made only minor changes to the default file, you can try
using "diff" to compare the version in the distribution with the one that
doesn't work.
(c) 
if all else fails, try posting the server.xml file to this group...

Cheers,

Simon

> -----Original Message-----
> From:	Donald Mullaney [SMTP:don@meltingsand.com]
> Sent:	Monday, December 18, 2000 6:51 PM
> To:	tomcat-user@jakarta.apache.org
> Subject:	At Value must be quoted.  Error
> 
>  
> Help.  I am running Apache 1.3 and Tomcat on Caldera's eServer.  I was
> trying make modifications to the default server.xml file.  After the
> modifications restarted tomcat and got the errors below.  I also returned
> the server.xml to the orginal state and I still get the same error.  Any
> ideas?  What is the error in reference to?  I have search the
> documentation and can't find anything that relates.
>  
> [root@host bin]# ./startup.sh
> Using classpath:
> .:/usr/local/jakarta-tomcat/lib/ant.jar:/usr/local/jakarta-tomcat/lib/jasp
> er.jar:/usr/local/jakarta-tomcat/lib/servlet.jar:/usr/local/jakarta-tomcat
> /lib/test:/usr/local/jakarta-tomcat/lib/webserver.jar:/usr/local/jakarta-t
> omcat/lib/xml.jar:/usr/java/lib/tools.jar:.:/usr/local/jakarta-tomcat/src:
> /usr/local/lib/postgresql.jar:/usr/local/jakarta-tomcat/src:/usr/local/jak
> arta-tomcat/src
> [root@host bin]# ERROR reading /usr/local/jakarta-tomcat/conf/server.xml
> At Value must be quoted.
> 
> FATAL: configuration error
> java.lang.NullPointerException:
>         at
> org.apache.tomcat.util.xml.XmlMapper.readXml(XmlMapper.java:221)
>         at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:143)
>         at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)
>  
> Thanks,
> 
> Donald Mullaney
>  
> Melting Sand, LLC
> 7660 E. Broadway Blvd Suite 308
> Tucson, AZ 85710
>  
> E-Mail: Don@MeltingSand.com <mailto:Don@MeltingSand.com>
> Phone: 520.918.SAND (7263)

Mime
View raw message