tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <br...@panix.com>
Subject Re: tomcat with apache mod_jk not being able to locate servlets
Date Wed, 06 Dec 2000 21:12:57 GMT
Did you add the following line in httpd.conf?

	AddModule mod_jk.c

Did you copy mod_jk.so in apache/libexec?  Also mod_rewrite.so should be there.

Did you configure tomcat/conf/workers.properties? You need to update 3 parameters:

	workers.tomcat_home=/jakarta-tomcat
	workers.java_home=/opt/jdk
	# For UNIX /
	ps=/
 

This is what my httpd.conf file looks like:

	# Note: The order in which modules are loaded is important.  Don't change
	# the order below without expert advice.
	#
	# Example:
	# LoadModule foo_module libexec/mod_foo.so
	LoadModule rewrite_module     libexec/mod_rewrite.so

	# BSA Added
	Include  /jakarta-tomcat/conf/mod_jk.conf

	#  Reconstruction of the complete module list from all available modules
	#  (static and shared ones) to achieve correct module execution order.
	#  [WHENEVER YOU CHANGE THE LOADMODULE SECTION ABOVE UPDATE THIS, TOO]
	ClearModuleList
	AddModule mod_env.c
	AddModule mod_log_config.c
	AddModule mod_mime.c
	AddModule mod_negotiation.c
	AddModule mod_status.c
	AddModule mod_include.c
	AddModule mod_autoindex.c
	AddModule mod_dir.c
	AddModule mod_cgi.c
	AddModule mod_asis.c
	AddModule mod_imap.c
	AddModule mod_actions.c
	AddModule mod_userdir.c
	AddModule mod_alias.c
	AddModule mod_rewrite.c
	AddModule mod_access.c
	AddModule mod_auth.c
	AddModule mod_so.c
	AddModule mod_setenvif.c
	# BSA Added
	AddModule mod_jk.c
<<*>>

And last, did you restart Tomcat followed by Apache?

Hopefully some of this might help! :)

Good luck,

Bryan


| Subject: tomcat with apache mod_jk not being able to locate servlets
| 
| /usr/local/tomcat/webapps/netconsole/WEB-INF/web.xml looks like this
| <servlet-name> webacc</servlet-name>
| <servlet-class>my.servlet.class.myservletclass</servlet-class>
| <init-param>
| <param-name>Config</param-name>
| <param-value>/my/webapps/config/file/myconfig.cfg</param-value>
| </init-param>
| <servlet-mapping>
|  <servlet-name>webacc</servlet-name>
| <url-pattern>/netconsole/webacc</url-pattern>
| 
| I copied the mod_jk.conf-auto to mod_jk.conf and added the lines
| 
| JkMount /netconosle/webacc ajp12
| and included the mod_jk.conf to my httpd.conf file.
| 
| One of the doc I read said to put the JkMount directive in my httpd.conf =
| file and I did that as well. I am at a loss cause it still is not working. =
| Can you think of something else that I should be doing? I also build my =
| own mod_jk.so file and using tomcat3.2 with apache 1.3.11. HELP!!!
| 
| Yong

Mime
View raw message