tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "RV Tobin" <rvto...@home.com>
Subject Re: Servlet display
Date Tue, 19 Dec 2000 16:56:46 GMT
I'm going through re-direct hell as we speak.  I am using Tomcat 3.1 and
when I insert a record to my MySQL database table, it works for the first
submit, but if I try to return to the form to make another post to the site,
I get the following showing up at the bottom of my page:

HTTP/1.1 200 Date: Tue, 19 Dec 2000 17:47:22 GMT Server: Apache/1.3.12
(Unix) (Red Hat/Linux) tomcat/1.0 PHP/3.0.15 mod_perl/1.21 Content-Language:
en Servlet-Engine: Tomcat Web Server/3.1 (JSP 1.1; Servlet 2.2; Java
1.3.0beta; Linux 2.2.14-5.0 i386; java.vendor=Sun Microsystems Inc.)
Keep-Alive: timeout=15, max=85 Connection: Keep-Alive Transfer-Encoding:
chunked Content-Type: text/html;charset=8859_1 800

Sometimes, the page I am trying to redirect to is added to the bottom of the
page with the form and submit button.  Sometimes, a "page has moved" message
appears at after the above server info, and if I click on the link provided,
I get sent to the page that I'm trying to redirect to.  All in all, it is
very frustrating.  I'm using UltraDev, and the code that redirects the page
is generated by UltraDev, and it works just fine on another page that I do
an update and then redirect on, but here I have nothing but trouble.

If I hit the refresh button before going to the posting form, I get properly
redirected, naturally, because it is like posting for the first time.  But
that is not what we should demand that users do if they want to post more
than once to the site.

The UD code is this, in case anyone can tell me what on earth might be going
on:

String MM_redirectPage = "../JspFiles/pdcThankyou.jsp";

// redirect with URL parameters
  if (MM_redirectPage.length() == 0) MM_redirectPage =
request.getRequestURI();
  if (MM_redirectPage.indexOf('?') == -1 && request.getQueryString() !=
null)
    MM_redirectPage += "?" + request.getQueryString();
  response.sendRedirect(response.encodeRedirectURL(MM_redirectPage));

I've posted to the UD site, and all I've received were responses from people
who are suffering from the same fate, and have the same setup, so if I fix
this problem, I'll be able to help a few other people who are sharing my
misery.

Thanks for any assistance.

Val

----- Original Message -----
From: "Hayer, Jagjeet" <Jagjeet.Hayer@softwareag.co.uk>
To: <tomcat-user@jakarta.apache.org>
Sent: Tuesday, December 19, 2000 11:35 AM
Subject: Servlet display


> Hi all,
>
> Has anyone had a problem with servlet display where a re-direction results
> in some of the actual JavaScript  being displayed within the browser
> display?
>
> Thanks in advance,
>
> Jag.
>
> The content of this e-mail is confidential, may contain privileged
material
> and is intended solely for the recipient(s) named above. If you receive
this
> in error, please notify Software AG immediately and delete this e-mail.
>
> Software AG (UK) Limited
> Registered in England & Wales 1310740
> Registered Office: Hudson House, Hudson Way,
> Pride Park, Derby DE24 8HS


Mime
View raw message