tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From brent.john...@homepoint.com
Subject Ajp13 Problems w Mod_JK
Date Thu, 16 Nov 2000 21:49:07 GMT
These are a few problems/questions I'm having upgrading and using Tomcat
3.1 to 3.2 with Ajp13 instead of 12 (for SSL).

1) As for SSL security can apache handle the security and THEN pass off the
request to Tomcat? (the pass to tomcat would be internal behind a firewall)

2) I've noticed when starting up and shutting down Tomcat, the context
manager keeps mentioning /examples, /test and /admin although I've
commented these sections out in the server.xml file.  Is there some other
configuration location to remove these?

3) If I change my JkMount to point to /somethingElse/*  instead of
/servlet/* in mod_jk.conf (included in this message) the server no longer
processes the servlets.. not really sure why.  I'm guessing there's some
other file I havent changed..

4) If I bypass apache and use the Tomcat internal HTTP server it seems to
be processing requests fine.  But if I try to use apache to grab the
request and pass it to a load balancing worker it doesnt seem to work.
Here's a copy of my conf file:

LoadModule jk_module libexec/mod_jk.so
AddModule mod_jk.c

JkWorkersFile /usr/local/jakarta/tomcat/conf/workers.properties
JkLogFile /usr/local/jakarta/tomcat/logs/mod_jk.log
JkLogLevel warn

JkMount /*.jsp lb1
JkMount /servlet/* lb1

<Location "/servlet/WEB-INF/">
    AllowOverride None
    deny from all
</Location>

<Location "/servlet/META-INF/">
    AllowOverride None
    deny from all
</Location>

I then have workers set up in the workers.properties like the following:

worker.list=lb1, ajp12, ajp13-10, ajp13-11

worker.lb1.port=4000
worker.lb1.host=localhost
worker.lb1.type=lb
worker.lb1.balanced_workers=ajp13-10, ajp13-11

worker.ajp12.port=4200
worker.ajp12.host=localhost
worker.ajp12.type=ajp12
worker.ajp12.lbfactor=1

worker.ajp13-10.port=4201
worker.ajp13-10.host=localhost
worker.ajp13-10.type=ajp13
worker.ajp13-10.lbfactor=5

worker.ajp13-11.port=4202
worker.ajp13-11.host=localhost
worker.ajp13-11.type=ajp13
worker.ajp13-11.lbfactor=5

I've also changed the server.xml file to point the Ajp13ConnectionHandler
to port 4000 (the load balanced worker).  Any ideas as to why this isnt
working?  All that happens, is Apache issues me an internal server error
(real helpful).

Thanks for the help!

- Brent


Mime
View raw message