tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jovie" <jo...@pure-commerce.com>
Subject RE: difficulty in running servlets
Date Tue, 14 Nov 2000 06:10:51 GMT
         try adding this
         <servlet-mapping>
        <servlet-name>hi</servlet-name>
        <url-pattern>/hi</url-pattern>
        </servlet-mapping>

         to your web.xml
  -----Original Message-----
  From: Rasika [mailto:ras@silicomp.com.sg]
  Sent: Tuesday, November 14, 2000 5:06 PM
  To: tomcat-user@jakarta.apache.org
  Subject: difficulty in running servlets


  Hello,
  I have installed TOMCAT with Apache. I followed your user guide and then
tomcat faqs to install tomcat.
  Now I am able to run .jsp files using both tomcat as well as Apache. I can
also run sample servlet provided alongwith examples. But I cannot run my own
servlet.
  I have stored itin webapps/root/web-inf/classes directory.
  I still don't understand which files need to be configured in order to run
my servlets?

  I have added following block to web.xml file
  <servlet>
        <servlet-name>hi</servlet-name>
        <servlet-class>hi</servlet-class>
      </servlet>

  where "hi" is the name of my servlet file. But when I try to run it
through browser giving command http://localhost:8040//hi where 8040 is
apache port(which I have changed ) it gives me 404 error.

  Can you please help me in configuring files so as to run my own servlets?

  Thanks,
  Rasikaj

Mime
View raw message