tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Saegesser" <marc.saeges...@apropos.com>
Subject RE: It didn't work
Date Wed, 22 Nov 2000 14:45:54 GMT
Sorry, I didn't realize you were running 3.1.  I've never configured that
version with IIS, only the 3.2bx versions, so my configuration might not
match yours exactly.  I've attached a sample .reg file that will configure
the ISAPI redirector registry entries assuming that Tomcat is installed in
c:\tomcat.  You'll need to edit the file to adjust the paths based on where
you've installed tomcat.  If the redirector can't open either the
worker_file or worker_mount_file the filter will fail to load (red arrow)
and you'll see an error message for the W3SVC in the system event log.

Hope this helps.

-----Original Message-----
From: Mohammed Nasr Shalaby [mailto:nasr@nasrit.net]
Sent: Wednesday, November 22, 2000 8:10 AM
To: tomcat-user@jakarta.apache.org
Subject: Re: It didn't work


Thank you very much Mark.
I have all the stuff setted as you descriped but I'm using a redirector of
96kb
(the one for 3.1) but it still wont work.
I think I've done the registry settings wrong, I've double checked it but
couldn't find any thing wrong with it. If have an NT server running tomcat
with
IIS would you please send me a snippet of the specified registry key so that
I
could make a checkup.
BTW I couldn't find the iis_redirect.reg-auto file you specified could you
please email a copy of it to me on nasr@nasrit.net??????? It will be a great
help for me and my collegus!

Marc Saegesser wrote:

> I've done several installs on WinNT and Win200 with IIS and I can tell you
> that it does work.  Without more details its hard to say what wrong with
> your configuration but here are a few common problems.
>
> 1)  Make sure the isapi_redirect.dll wasn't corrupted by the download.  It
> should 112Kb, if your using 3.2b6 or higher.
> 2)  Make sure the registry entries for the ISAPI redirector are correct.
> I've done the registry stuff by hand I usually get it wrong.  Look for an
> iis_redirect.reg-auto in the conf directory.  This file gets created for
you
> automatically.  Take a look at it to make sure the settings look OK and
then
> rename the file to iis_redirect.reg and run it to create the registry
> entries for you.
> 3)  Step 8 under Configuring the ISAPI Redirector says to add the "Filter
> Dlls" key if your using PWS.  PWS is a piece of junk web server that ships
> with WinNT Worstation (as an aside, NEVER install this web server).  From
> your email it looks like your using IIS from the NT 4.0 Option Pack.  This
> server is sometimes refered to as the Personal Web Server to differentiate
> it from the web server for NT Server.  Anyway, if your using IIS from the
> option pack, don't create the "Filter DLLs" registry key.  If you do, the
> isapi_redirector won't load.
>
> -----Original Message-----
> From: Mohammed Nasr Shalaby [mailto:nasr@nasrit.net]
> Sent: Tuesday, November 21, 2000 11:58 AM
> To: tomcat-user@jakarta.apache.org
> Subject: It didn't work
>
> Hi All
>
> I'm trying to install tomcat on IIS4/NT4 but it just wont work, I've
> installed all the needed files, performed all steps from the "TomCat IIS
> howto" document found on the server but all didn't work. The ISAPI
> filter in the Internet Service Manager alwayes gives me a red arrow
> pointing down beside the jakarta filter. Could any one tell me how to
> make it run??


Mime
View raw message