tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Day, Evan" <Evan....@SUMMITSITE.COM>
Subject tomcat 3.2b5 - worker not found?
Date Tue, 14 Nov 2000 18:16:04 GMT
Platform: Redhat 7.0, OpenSSL 0.9.6, Apache 1.3.14 w/ mm 1.1.3 and mod_ssl
2.7.1, tomcat 3.2b5
Vanilla configurations from fresh builds.

Apache works fine on its own in both HTTP and HTTPS.  Tomcat works find
standalone.

When I turn on mod_jk in apache to run servlets from the apache server, it
works fine if I run apache without SSL.  However, when I do an apachectl
startssl, I start seeing the following in the mod_jk.log:

[jk_uri_worker_map.c (344)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (406)]: jk_uri_worker_map_t::map_uri_to_worker, Found a
match ajp12
[jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
[jk_worker.c (127)]: wc_get_worker_for_name, done did not found a worker
[jk_uri_worker_map.c (344)]: Into jk_uri_worker_map_t::map_uri_to_worker
[jk_uri_worker_map.c (406)]: jk_uri_worker_map_t::map_uri_to_worker, Found a
match ajp12
[jk_worker.c (123)]: Into wc_get_worker_for_name ajp12
[jk_worker.c (127)]: wc_get_worker_for_name, done did not found a worker

I've looked through my httpd.conf (straight out of the apache distribution
with no changes except to include mod_jk.conf), the mod_jk.conf, and the
worker.properties files (only changes were to point the tomcat home and java
directories to the right places).  Haven't been able to find anything in the
archives or various FAQs to shed any light on this.

Any ideas what might be wrong?

Thanks

            o      _      _         _
   _o      /\_   _ |\o   (_)\__/o  (_)
 _< \_    _>(_) (_)/<_     \_| \   _|/' \/
(_)>(_)o (_) o   o  (_) o  (_)    (_)'  _\o_
---------------------------------------------
Evan Day
SUMMIT Information Systems
evan.day@summitsite.com 
(800) 937-7500 x6301


Mime
View raw message