tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raghu Havaldar <rhaval...@objectspace.com>
Subject RE: jar's still not picked up in WEB-INF/lib
Date Wed, 01 Nov 2000 14:34:08 GMT
The Context setup is for the web-app.
 
I do not think it is a good idea to put app-depedent
libs under $TOMCAT/lib. 
 
Just for experimentation, I tried placing the JARs under
$TOMCAT/lib and $TOMCAT/webapps/web-inf/lib.  Does
not work.
 
Tried with 3.1 and 3.2beta6 on WinNT 4.0. 
 
-raghu

-----Original Message-----
From: Leon Palermo [mailto:leonp@zedak.com]
Sent: Wednesday, November 01, 2000 7:31 AM
To: tomcat-user@jakarta.apache.org
Subject: Re: jar's still not picked up in WEB-INF/lib


I would definitely set up a context in server.xml like this:
 
<Context path="/Oasis"
 docBase="webapps/Oasis" 
 debug="0" 
 reloadable="true" >
</Context>
 
That should solve you problem.  Otherwise, just put the .jar files in the
D:\Java\jakarta-tomcat\lib directory.  Then the jars would be available for
all applications served by tomcat.
 
Leon Palermo
Zedak Corporation
Valhalla, NY

----- Original Message ----- 
From: Bill Pfeiffer <mailto:wsplist1@tampabay.rr.com>  
To: Tomcat <mailto:tomcat-user@jakarta.apache.org>  
Sent: Wednesday, November 01, 2000 8:13 AM
Subject: Re: jar's still not picked up in WEB-INF/lib

I am experiencing the same problem that others have reported on this topic.
I explicitly set my Tomcat classpath to be sure of no redundancies in the
jars.  I have a Tomcat startup batch file with one line that adds in all the
jars in my WEB-INF\lib to the classpath explicitly.  When I comment that
line out, I get the classnotfound errors.  When I put it back in, my web app
runs fine.  Obviosly I want the line commented out and have the jars picked
up in the lib dir, but that aint happening.
 
Because the jars work when explicitly included in the classpath, I conclude
that the jars are not corrupt.  I also conclude, based on commenting out the
explicit lib jars classpath, that there are not redundant jars in the
classpath.  I have also checked other sources for possible classpath jar
redundancies and I am just not finding any.
 
 I am running under Win2000 using jdk1.3.  
 
These is the exact dir structure I have set up:
 
D:\Java\jakarta-tomcat\webapps
D:\Java\jakarta-tomcat\webapps\Oasis
D:\Java\jakarta-tomcat\webapps\Oasis\jsp
D:\Java\jakarta-tomcat\webapps\Oasis\META-INF
D:\Java\jakarta-tomcat\webapps\Oasis\resources
D:\Java\jakarta-tomcat\webapps\Oasis\WEB-INF
D:\Java\jakarta-tomcat\webapps\Oasis\WEB-INF\classes
D:\Java\jakarta-tomcat\webapps\Oasis\WEB-INF\lib
 
I have gone through Craig McClanahans list of things to check and all seems
to be as it should.
 
Any hope for a fix?  Should I continue to look at my config?  I have heard
some people talk about setting up an explicit context for the app in the
server.xml.  Does this solve the problem consistantly?
 
 
TIA,
 
Bill Pfeiffer


Mime
View raw message