tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Baillard <obaill...@bct-technology.com>
Subject Re: Questions re: Tomcat and IBM VAJ
Date Tue, 21 Nov 2000 06:51:01 GMT
Hello,

http://www7.software.ibm.com/vad.nsf/Data/Document2390?OpenDocument&p=1&BCT=3&Footer=1


Bye!
Olivier Baillard



At 16:58 20.11.00 -0500, you wrote:
>Hello. I'm trying to get Tomcat running under Windows 'NT with IBM VAJ.
>Unfortunately, I haven't been able to make everything work together just yet,
>and would greatly appreciate your help in resolving what is probably a very
>simple problem.
>
>Environment
>  - MS-Windows 'NT 4.0
>  - IBM VAJ version 3.0 for J2SE 1.2 (the free, up to 750 classes version of
>VAJ)
>  - Tomcat 3.1
>
>All of the above have been downloaded and installed into their "default"
>locations. Environment variables include the following:
>CLASSPATH=C:\IBMVJava2\eab\runtime30
>JAVA_HOME=C:\IBMVJava2\eab\runtime30
>TOMCAT_HOME=C:\jakarta\tomcat
>
>When I enter the following commands:
>C:\jakarta\tomcat\bin>startup
>Starting tomcat in new window
>Using classpath:
>c:\jakarta\tomcat\classes;c:\jakarta\tomcat\lib\webserver.jar;c
>:\jakarta\tomcat\lib\jasper.jar;c:\jakarta\tomcat\lib\xml.jar;c:\jakarta\tomca
>
>t\
>lib\servlet.jar;c:\j2sdkee1.2.1\lib\tools.jar;C:\IBMVJava2\eab\runtime30;
>C:\jakarta\tomcat\bin>
>
>A new MS-DOS Command Prompt window opens with the title
>"c:\WINNT\system32\java.exe". It contains the following output, presumably
>from Tomcat:
>Context log: path="/examples" Adding context path="/examples"
>docBase="webapps/
>examples"
>Context log: path="" Adding context path=""  docBase="webapps/ROOT"
>Context log: path="/test" Adding context path="/test"  docBase="webapps/test"
>Starting tomcat. Check logs/tomcat.log for error messages
>Starting tomcat install="c:\jakarta\tomcat" home="C:\jakarta\tomcat"
>classPath="
>c:\jakarta\tomcat\classes;c:\jakarta\tomcat\lib\webserver.jar;c:\jakarta\tomca
>
>t\
>lib\jasper.jar;c:\jakarta\tomcat\lib\xml.jar;c:\jakarta\tomcat\lib\servlet.jar
>
>;c
>:\j2sdkee1.2.1\lib\tools.jar;C:\IBMVJava2\eab\runtime30;"
>Context log: path="/admin" Automatic context load
>docBase="C:\jakarta\tomcat\web
>apps\admin"
>Context log: path="/admin" Adding context path="/admin"
>docBase="C:\jakarta\tom
>cat\webapps\admin"
>
>The logs do not seem to indicate an error message -- the tomcat.log contains
>the following:
>Starting endpoint port="8080"
>handler="org.apache.tomcat.service.http.HttpConnectionHandler" Starting
>endpoint port="8007"
>handler="org.apache.tomcat.service.connector.Ajp12ConnectionHandler"
>
>
>While this seems to indicate that Tomcat is working properly, I know it
>isn't. I have two files, simple.html and simple.jsp (downloaded from Wrox, as
>I'm using their Professional JSP book as a reference).
>====begin simple.html ====
>
><HEAD>
><TITLE>Simple JSP Example</TITLE>
></HEAD>
>
>
>
>How many times?
>
><FORM METHOD="GET" ACTION="SimpleJSP.jsp">
><INPUT TYPE="TEXT" SIZE="2" NAME="numtimes">
><INPUT TYPE="SUBMIT">
></FORM>
>
>
>
>==== end simple.html ====
>==== begin simple.jsp ====
><%@ page language="java" %>
>
>
><HEAD>
><TITLE>Simple JSP Example</TITLE>
></HEAD>
>
>
>
>
>   <% int numTimes = Integer.parseInt(request.getParameter("numtimes"));
>      for (int i = 0; i < numTimes; i++) {
>   %>
>        Hello, world!
>   <% }
>   %>
>
>
><%@ include file="PageFooter.html" %>
>
>
>
>==== end simple.jsp ====
>
>simple.html loads fine. When I enter a number into the resultant form
>simple.jsp is loaded but the JSP servlet code IS NOT executed. What am I
>doing wrong?
>
>Luke Hohmann


Mime
View raw message