tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: http 1.1 request line with full url
Date Thu, 16 Nov 2000 19:51:10 GMT
Stefan Haustein wrote:

> Hi,
>
> does anybody know how to convince
> Tomcat to process "true" HTTP 1.1 requests
> having the full URL in the request line, e.g.:
>
>   POST http://www.foo.org/bar HTTP/1.1
>
> If I try this, I get a 409 error.
>
>   POST /bar HTTP/1.1
>
> works fine, but I have a client that
> sends the full URL, and HTTP 1.1 says
> the server MUST be able to process
> this... :-(
>
> Best,
> Stefan
>

Stefan,

Which version of Tomcat are you working with?  Tomcat 3.x does not
support HTTP/1.1 in stand-alone mode, and therefore is not required to
handle absolute URIs.  (I haven't tried it, but this should work for
Tomcat 3.x behind Apache).

For Tomcat 4.0-m4, I get a "404" error when I try this, which is
definitely a bug (because the absolute URI form is not being parsed).
Could you do me a favor and log a bug in our Bug Tracking System so that
we'll add this to the list of things to get fixed?  Sometimes bug
reports in the mailing lists get lost in the confusion.  You can report
this bug at:

    http://znutar.cortexity.com/index.jsp

>
> --
> Stefan Haustein
> Univ. Dortmund, FB 4, LS 8   tel: +49 231 755 2499
> Baroper Str. 301             fax: +49 231 755 5105
> D-44221 Dortmund (Germany)   www-ai.cs.uni-dortmund.de

Craig McClanahan



Mime
View raw message