tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Ellis <jdell...@home.com>
Subject Re: Problems getting generated images through the IIS connector.
Date Tue, 14 Nov 2000 16:25:01 GMT
This is just a guess, but maybe it has something to do with the extension
(.jpg).  Maybe IIS is resetting the mime type after you have sent it.  Try (if
you are trying this already then disreguard this message) making the servlet
mapping more like this:
/root/binaries/image/*, then build the query string like this
/root/binaries/images/<query_string>/image.jpg and see if that helps.  In your
servlet, you can use javax.servlet.http.HttpUtils/parseQueryString to parse the
query string for you.

Hope it helps,

John

Etienne Baert wrote:

> Hi,
>
> I do have have the same problem, I am interested in sharing any solution
> you can find.
>
> Etienne
>
> -----Original Message-----
> From: Michel Lehon [mailto:Michel.lehon@outwares.com]
> Sent: mardi 14 novembre 2000 8:17
> To: tomcat-user@jakarta.apache.org
> Subject: Problems getting generated images through the IIS connector.
>
> Hi,
>
> We are having a wierd problem here... here's the (short) story.
>
> We are generating JPEG Images from one of our servlets (Java2D and the sun
> Jpeg codec).
>
> It shows up correctly in IE without problems... but when we try to print the
> page (yep, some of our users want to do that), the images do not show.
>
> The wired thing is that it only happens when we access the images through
> IIS (using the isapi_redirect filter).
> When we access the image through tomcat (port 8080) they show and print
> correctly.
>
> I tried to look a little bit further...
> In IE when I take the properties of the image (coming trough Tomcat:8080) it
> knows the size (in pixels and in bytes) and it shows it mime/type (JPEG).
> When I do the same trough IIS it does not know the size (in bytes) nor its
> mime type. Even save image does not work as expected (it only saves in BMP).
>
> I almost forgot to mention versions... I does that under Tomcat 3.1 (final)
> and the new 3.2b7, I'm going to test with the 4.0M4 very soon.
>
> Does anyone has any idea ???
>
> Thanks a lot.
>
> Michel Lehon.
> Michel.Lehon@Outwares.com
> SAS Data Warehousing and Web Enablement.


Mime
View raw message