tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Tiemann <pa...@center7.com>
Subject 3.2b6 mod_jserv.so mod_jk.so garbled API module structure...
Date Wed, 08 Nov 2000 18:39:41 GMT
I'm attempting to install a 3.2 version of tomcat in order to achieve
virtual hosts in a single JVM.

When I try to start apache I get this:

"Starting httpd: Syntax error on line 1 of
/opt/apache/conf/tomcat-apache.conf:
API module structure `jserv_module' in file
/opt/apache/libexec/mod_jserv.so is garbled - perhaps this is not an
Apache module DSO?"

I thought it might be my installation of apache (which was previously
working with the old mod_jserv.so with DSO).  I downloaded 1.3.14 and
built it, just in case.  These are were my exact parameters to the
apache build process:

./configure --prefix=/opt/apache --enable-rule=SHARED_CORE
--enable-module=so
make
make install

The first mod_jserv.so I tried was the one I downloaded from the 3.2b6
bin/linux/i386/ download directory.  Since it didn't work, I feared that
it might be the netscape save-file problem, so I downloaded the source
for 3.2b6 and built it in the src/native/apache/jserv directory with the
following command:

/opt/apache/bin/apxs -c *.c -o mod_jserv.so

That built a mod_jserv.so file that I put into the /opt/apache/libexec/
directory, and tried again, but no luck.  I got the same 'garbled'
message again.  So I diffed the file I had just built and the one I got
from jakarta.apache.org, and they were the same.

I went to the user mailing list archive hosted on mikal.org and did some
looking around.  Someone said to use ld to create the mod_jserv.so file
manually from the .o files that are created from the apxs compile.   I
did that too, and got a mod_jserv.so file that did differ from the one
on jakarta.apache.org, but it still provided the exact same error
message when I try to start apache.

I've debugged as far as I know how without reading through the code and
attempting to find a bug.

Does anyone have any ideas that would save me the time of scrutinizing
the source? :)

Any and all help is greatly appreciated!
Paul Tiemann


Mime
View raw message