tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xia, Alex" <A...@sonusnet.com>
Subject FW: Critical Bug: SSL failed for Tomcat 3.2 Beta 8
Date Wed, 22 Nov 2000 21:43:44 GMT

I have downloaded the Tomcat 3.2 Beta 8 source and compiled myself. The same
thing happened.

BUT, once I disabled FORM based authentication, SSL seems to work.

The logical conclusion is that SSL does NOT work with FORM based
authentication for Tomcat 3.2 Beta 8. But is used to work for Tomcat 3.2
Beta 5.

I would still think this is a critical bug.

Thanks,

Alex X. Xia
Sonus Networks, Inc.
(978) 392-8114


-----Original Message-----
From: Xia, Alex [mailto:AXia@sonusnet.com]
Sent: Wednesday, November 22, 2000 1:36 PM
To: tomcat-user@jakarta.apache.org
Subject: RE: Critical Bug: SSL failed for Tomcat 3.2 Beta 8


No, I did not build from the source. I dowonloaded Tomcat 3.2 Beta 8 from
the bin directory.

Yes, I put the three JSSE jar files under ~jakarta/lib as well as under
~jdk1.2.2/jre/lib/ext.

I unjared the webserver.jar and made sure that SSLSocketFactory is under
org/apache/tomcat/net.

One more important point: I am using FORM based logins for my
authentications.

The same exact setup works for Tomcat 3.2 Beta 5. It stopped working for
Tomcat 3.2 Beta 7 & 8.

Thanks,

Alex X. Xia
Sonus Networks, Inc.
(978) 392-8114


-----Original Message-----
From: Stefán F. Stefánsson [mailto:stebbi@decode.is]
Sent: Wednesday, November 22, 2000 10:41 AM
To: tomcat-user@jakarta.apache.org
Subject: RE: Critical Bug: SSL failed for Tomcat 3.2 Beta 8


Did you build from source?

If so, did you have the JSSE jars in the classpath when you did that?

Regards, Stefan.

-----Original Message-----
From: Xia, Alex [mailto:AXia@sonusnet.com]
Sent: 21. nóvember 2000 22:28
To: tomcat-user@jakarta.apache.org
Subject: Critical Bug: SSL failed for Tomcat 3.2 Beta 8


I have installed Tomcat 3.2 Beta 8 on NT and made the following change
to
server.xml to enable SSL:

        <Connector
className="org.apache.tomcat.service.PoolTcpConnector">
            <Parameter name="handler" 
 
value="org.apache.tomcat.service.http.HttpConnectionHandler"/>
            <Parameter name="port" 
                value="443"/>
            <Parameter name="socketFactory" 
                value="org.apache.tomcat.net.SSLSocketFactory" />
            <Parameter name="secure" 
                value="true" />
        </Connector>

And I have followed the instruction to create SSL certificate.

The same exact configuration worked for Tomcat 3.2 Beta 5.

However, when I tried to access my jsp, I got the following error on the
server:

java.io.IOException: The filename, directory name, or volume label
syntax is
inc
orrect
        at java.io.Win32FileSystem.canonicalize(Native Method)
        at java.io.File.getCanonicalPath(File.java:441)
        at org.apache.tomcat.util.FileUtil.safePath(FileUtil.java,
Compiled
Code
)
        at org.apache.tomcat.core.Context.getRealPath(Context.java:794)
        at
org.apache.tomcat.request.StaticInterceptor.requestMap(StaticIntercep
tor.java:191)
        at
org.apache.tomcat.core.ContextManager.processRequest(ContextManager.j
ava, Compiled Code)
        at
org.apache.tomcat.core.ContextManager.internalService(ContextManager.
java:771)
        at
org.apache.tomcat.core.ContextManager.service(ContextManager.java:743
)
        at
org.apache.tomcat.service.http.HttpConnectionHandler.processConnectio
n(HttpConnectionHandler.java:210)
        at
org.apache.tomcat.service.TcpWorkerThread.runIt(PoolTcpEndpoint.java,
 Compiled Code)
        at
org.apache.tomcat.util.ThreadPool$ControlRunnable.run(ThreadPool.java
, Compiled Code)
        at java.lang.Thread.run(Thread.java, Compiled Code)
2000-11-21 05:18:48 - Ctx(  ): 404 R(  +
:?(û?¤?¦¦¬\ò+îå+0r½+a+??+÷î¶2c¦~ ?
? ?

 + null) null

It seems like Tomcat did not decript the URL for SSL thus creating the
problem.

I would say this is a critical bug.

Thanks,

Alex X. Xia
Sonus Networks, Inc.
(978) 392-8114

Mime
View raw message