tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <javabet...@yahoo.com>
Subject RE: Error parsing JSP with tag library -- how do I track down wha t's wrong?
Date Tue, 28 Nov 2000 22:06:05 GMT
Try referencing the dtd for web.xml as follows:

<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web 		   
Application 2.2//EN"
    "http://java.sun.com/j2ee/dtds/web-app_2.2.dtd">

Dave
--- Duane Morse <dmorse@eldocomp.com> wrote:
> I don't find "web-app" defined as a tld tag in the
> spec.  It's a tag in
> web.xml,
> but not in the tld.
> 
> I'm trying to use Tomcat 3.1.
> 
> Duane Morse, Eldorado Computing Inc., Phoenix AZ
> 
> 
> -----Original Message-----
> From: Pierre Delisle [mailto:pierre.delisle@sun.com]
> Sent: Tuesday, November 28, 2000 2:25 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Re: Error parsing JSP with tag library --
> how do I track down
> what's wrong?
> 
> 
> Which version of tomcat?
> 
> XML parser validation failed because of a 'web-app'
> tag that
> is not accepted by the DTD against which it is being
> validated. 
> Do you have that tag in your TLD? If so, that's the
> problem.
> 
> Send your TLD or web.xml if you want more help.
> 
> 	-- Pierre
> 
> Duane Morse wrote:
> > 
> > I'm "porting" software from JRun, where it all
> runs fine, to Tomcat, and a
> > JSP which uses a simple tag extension fails with
> the following error:
> > org.apache.jasper.JasperException: Unable to open
> taglibrary
> > www.eldocomp.com/webpac/taglibs/utils : Parse
> Error in the tag library
> > descriptor: Element type "web-app" is not
> declared.
> > 
> > In this case, "www.eldocomp.....utils" is the
> taglib-uri value in web.xml,
> > and the taglib-location value is
> WEB-INF/lib/utils_tl.jar, and the jar
> file
> > includes "META-INF/taglib.tld".
> > 
> > Considering that JRun processes web.xml and this
> stuff fine, what's the
> > problem here?  I can't find
> > anything in the log files or the console to
> enlighten me, and the
> temporary
> > .java file created for the JSP is empty.
> > I have the debug level set to 9, but that doesn't
> seem to help.
> > 
> > Duane Morse, Eldorado Computing Inc., Phoenix AZ


__________________________________________________
Do You Yahoo!?
Yahoo! Shopping - Thousands of Stores. Millions of Products.
http://shopping.yahoo.com/

Mime
View raw message