tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iuliano, James" <JIuli...@pesolutions.com>
Subject Tomcat NT headaches...
Date Thu, 02 Nov 2000 19:22:26 GMT
I've installed Jakarta Tomcat on Windows NT and there are a couple of
(seemingly un-related) problems:

1.  When I go to %TOMCAT_HOME%\bin, and run "tomcat start", I get the
following error message:

"Registry key 'Software\JavaSoft\Java Runtime Environment\CurrentVersion'
has value '1.3', but '1.2' is required."

I have the exact same setup on my Windows2000 box, and it works just fine
(with JRE set to 1.3).


2.  I've set up the NT service using the jk_nt_service.exe, and when I try
to launch it, I get an
error dialog that says:

"Could not start the JakartaTomcat service on \\COMSTOCK

Error 2140: An internal Windows NT error occurred."


I can configure the JRE to 1.2 in the registry, and it fixes problem #1, but
does not
fix problem #2.

I really want to run this as a service, and only have to have one JRE/JDK on
the
box.  I don't understand why it wants 1.2 on NT, but its OK with 1.3 on
Windows2000.

Thanks.

James Iuliano
Technical Lead
425-893-7242
mailto:jiuliano@filenet.com


Mime
View raw message