tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Pfeiffer" <wspli...@tampabay.rr.com>
Subject Re: jar's still not picked up in WEB-INF/lib
Date Wed, 01 Nov 2000 13:26:04 GMT
Forgot to mention, I'm using Tomcat 3.2beta6.
  ----- Original Message ----- 
  From: Bill Pfeiffer 
  To: Tomcat 
  Sent: Wednesday, November 01, 2000 8:13 AM
  Subject: Re: jar's still not picked up in WEB-INF/lib


  I am experiencing the same problem that others have reported on this topic.  I explicitly
set my Tomcat classpath to be sure of no redundancies in the jars.  I have a Tomcat startup
batch file with one line that adds in all the jars in my WEB-INF\lib to the classpath explicitly.
 When I comment that line out, I get the classnotfound errors.  When I put it back in, my
web app runs fine.  Obviosly I want the line commented out and have the jars picked up in
the lib dir, but that aint happening.

  Because the jars work when explicitly included in the classpath, I conclude that the jars
are not corrupt.  I also conclude, based on commenting out the explicit lib jars classpath,
that there are not redundant jars in the classpath.  I have also checked other sources for
possible classpath jar redundancies and I am just not finding any.

   I am running under Win2000 using jdk1.3.  

  These is the exact dir structure I have set up:

  D:\Java\jakarta-tomcat\webapps
  D:\Java\jakarta-tomcat\webapps\Oasis
  D:\Java\jakarta-tomcat\webapps\Oasis\jsp
  D:\Java\jakarta-tomcat\webapps\Oasis\META-INF
  D:\Java\jakarta-tomcat\webapps\Oasis\resources
  D:\Java\jakarta-tomcat\webapps\Oasis\WEB-INF
  D:\Java\jakarta-tomcat\webapps\Oasis\WEB-INF\classes
  D:\Java\jakarta-tomcat\webapps\Oasis\WEB-INF\lib

  I have gone through Craig McClanahans list of things to check and all seems to be as it
should.
   
  Any hope for a fix?  Should I continue to look at my config?  I have heard some people talk
about setting up an explicit context for the app in the server.xml.  Does this solve the problem
consistantly?


  TIA,

  Bill Pfeiffer

Mime
View raw message