tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gareth Cantrell" <>
Subject Errors compiling JSP pages
Date Thu, 09 Nov 2000 12:37:01 GMT
I am using jBoss (BETA_PROD_04) and Tomcat 3.2b6, with tomcat as an embedded service in jboss.
I have tried configuring without embedded and using tomcat 3.2b4 and b5 as well... and i've
tried on 
windows and linux... all possible combinations... and still get it... :(
However, when using jboss beta 2, and tomcat 3.2b6, and deploying the jar and war files separately
in the jboss/deploy and jakarta-tomcat/webapps directories respectively, everything works
I'm at a loss here.... could someone *please* help.....

When I deploy my .ear file, I get the following message:

[EmbeddedTomcat] ContextManager: Adding context Ctx(  )
count = 0, total = 57
[EmbeddedTomcat] cannot load servlet name: jsp

......and when trying to access the index.jsp page, the following is spewed out ......

[EmbeddedTomcat] path="" :jsp: init
count = 0, total = 57
count = 0, total = 22
count = 0, total = 57
count = 0, total = 22
[EmbeddedTomcat] java.lang.InternalError: jzentry == 0
[EmbeddedTomcat]        at$2.nextElement(Unknown Source)
[EmbeddedTomcat]        at
[EmbeddedTomcat]        at
[EmbeddedTomcat]        at
[EmbeddedTomcat]        at
[EmbeddedTomcat]        at
[EmbeddedTomcat]        at
[EmbeddedTomcat]        at org.apache.jasper.compiler.SunJavaCompiler.compile(
[EmbeddedTomcat]        at org.apache.jasper.compiler.Compiler.compile(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JspServlet.doLoadJSP(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JasperLoader12$
[EmbeddedTomcat]        at Method)
[EmbeddedTomcat]        at org.apache.jasper.servlet.JasperLoader12.loadJSP(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JspServlet.loadJSP(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JspServlet$JspServletWrapper.loadIfNecessary(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JspServlet$JspServletWrapper.service(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JspServlet.serviceJspFile(
[EmbeddedTomcat]        at org.apache.jasper.servlet.JspServlet.service(
[EmbeddedTomcat]        at javax.servlet.http.HttpServlet.service(
[EmbeddedTomcat]        at org.apache.tomcat.core.ServletWrapper.doService(
[EmbeddedTomcat]        at org.apache.tomcat.core.Handler.service(
[EmbeddedTomcat]        at org.apache.tomcat.core.ServletWrapper.service(
[EmbeddedTomcat]        at org.apache.tomcat.core.ContextManager.internalService(
[EmbeddedTomcat]        at org.apache.tomcat.core.ContextManager.service(
[EmbeddedTomcat]        at org.apache.tomcat.service.http.HttpConnectionHandler.processConnection(
[EmbeddedTomcat]        at org.apache.tomcat.service.TcpWorkerThread.runIt(
[EmbeddedTomcat]        at org.apache.tomcat.util.ThreadPool$
[EmbeddedTomcat]        at Source)
[EmbeddedTomcat] Ctx(  ): JasperException: R(  + /index.jsp + null) Unable to compile class
for JSPerror: An error has occurred in the compiler; please file a bug report (
1 error

Gareth Cantrell

View raw message