tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritwick Dhar <ritwic...@EASTPOINT.COM>
Subject RE: HANDLER THREAD PROBLEM: Stream closed prematurely
Date Fri, 24 Nov 2000 16:46:17 GMT

Unfortunately, I'm already running it with Apache. (IBM HTTP Server based on
Apache with SSL). Thanks for the reply.


-----Original Message-----
From: Roytman, Alex []
Sent: Friday, November 24, 2000 10:53 AM
To: ''
Subject: RE: HANDLER THREAD PROBLEM: Stream closed prematurely

If you are running Tomcat standalone I would suggest to try it with Apache
web server.
We had some problems with tomcat built in web server - 
POST input stream would only give you first 1300 bytes of POST data 
and some other problems I do not remember. 
I believe apache inherited it from Sun Web server which had these problems.
However all these problems were not present when we access tomcat via Apache
web server


-----Original Message-----
From: Ritwick Dhar [mailto:ritwick_d@EASTPOINT.COM]
Sent: Friday, November 24, 2000 11:35 AM
To: ''
Subject: HANDLER THREAD PROBLEM: Stream closed prematurely


This problem is driving me nuts. I've tried debugging this, but nothing yet.
I was hoping someone on this list will have come accross this before.

Case: I have a servlet (server) that accepts POST requests (content-type=
application/x-ofx), and sends back a OFX response. I have another servlet
(client), that opens a URL to the server, writes the request, and reads the
reponse. Simple.

The problem is, the moment the client tries to call
'urlConn.getInputStream()' to get an inputstream from the server, I get this
(on the server console):

HANDLER THREAD PROBLEM: Stream closed prematurely Stream closed prematurely
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at<init>(Compiled Code)
iled Code)
(Compiled Code)
        at Code)
        at Code)

What's really driving me up the wall is that this works perfectly fine with
Both WebSphere and JRun. Is this something particular to Tomcat??

Thanks for all help


View raw message