tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "carnell" <carn...@iabg.de>
Subject Re: mod_jk does not compile (3.2b7)
Date Tue, 14 Nov 2000 07:47:20 GMT
For Solaris:

apxs -o
mod_jk.so -DSOLARIS -I../jk -I/usr/java/include -I/usr/java/include/solaris 
-c *.c ../jk/*.c
On some systems, this will build the module correctly, but will fail at
runtime with a "symbol "fdatasync" not found". To fix, add -lposix4 just
before the -c in the above command.

as in the howto mod-jk. I had to add the -lposix4 in the 3.2b6 release.

before the -c as instructed:

"/opt/apache/bin/apxs -o
mod_jk.so -DSOLARIS -I../jk -I/usr/java/include -I/usr/java/include/solaris
-lposix4 -c *.c ../jk/*.c"


----- Original Message -----
From: "John Tangney" <jtangney@knowledgeplanet.com>
To: <tomcat-user@jakarta.apache.org>; "carnell" <carnell@iabg.de>
Sent: Monday, November 13, 2000 6:59 PM
Subject: Re: mod_jk does not compile (3.2b7)


> On 11/13/00 2:54 AM, carnell at carnell@iabg.de wrote:
>
> > apxs:Break: Command failed with rc=16711680
> >
> > And it worked under 3.2 b6 :( Any ideas?
>
> Yeah. I worked through a similar one. It's probably something in apxs
> itself. In my case, I needed to modify $CFG_LD_SHLIB inside apxs. Maybe
your
> problem is something similar...?
>
> Your output line that ends with  -lposix4  looks suspcious. Shouldn't
those
> options go before the list of files?
>
> Also check that you have specified args to apxs in the correct order. Yes,
> order matters.
>
> Good luck!
> --johnt
>
>


Mime
View raw message