tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kenneth topp <cau...@prodigy.net>
Subject Re: is it ture that tomcat doesnt work with JDK 1.2
Date Thu, 12 Oct 2000 20:48:37 GMT

Latest CVS stuff?  for 3.2 or 4.0?

I reiterate that I'm aware (from this list or another) that they had
rejected a patch because it broke compatability with jdk 1.1.x.  This was
most likely in the 3.x branch (and was within the last couple weeks).

Perhaps tomcat-dev would care to enlighten us as to the official position.

Kenneth Topp

---
 to unsubscribe: tomcat-user-unsubscribe@jakarta.apache.org
 for more info: http://jakarta.apache.org/getinvolved/mail.html

On Thu, 12 Oct 2000, Spencer Proffit wrote:

> When I tried to compile the latest CVS stuff with 1.1.8 I got the
> following error:
> 
> ----
> tomcat.jar:
>     [javac] Compiling 1 source file to
> /home/spencer/jakarta/build/tomcat/classes
>     [javac]
> /home/spencer/jakarta/jakarta-tomcat/src/share/org/apache/tomcat/startup/Main.java:162:
> Method setProperty(java.lang.String, java.lang.String) not found in
> class java.lang.System.
>     [javac]                 System.setProperty( "tomcat.home", h );
>     [javac]                                   ^
>     [javac] 1 error
> 
> BUILD FAILED
> ----
> 
> System.setProperty(java.lang.String, java.lang.String) is from 1.2 API
> 
> kenneth topp wrote:
> > 
> > Matthias
> > 
> > This is so false.  They reject patches if it breaks 1.1 compatability (for
> > the moment at least).
> > 
> > Good luck,
> > 
> > Kenneth Topp
> > 
> > ---
> >  to unsubscribe: tomcat-user-unsubscribe@jakarta.apache.org
> >  for more info: http://jakarta.apache.org/getinvolved/mail.html
> > 
> > On Thu, 12 Oct 2000, [iso-8859-1] Matthias Nöthe wrote:
> > 
> > >
> > > hi everyone,
> > > does anyone know if is it true that tomcat doesnt work with JDK 1.2 ?
> > >
> > > thanks for an advice
> > >
> > > matthias
> > >
> 
> 


Mime
View raw message