tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonio Vazquez <vazqu...@aucland.com>
Subject RE: Installing Tomcat under JDK 1.1.8
Date Wed, 18 Oct 2000 13:37:23 GMT
Hi Mirek,
I tried to do it with jdk 1.1.7 under NT but I can`t.
Then I tried with jdk 1.2.2 and... you can imagine.
I haven?t got any problem, so I recommend you that.
I don?t understand it but install with a earlier jdk version seems
impossible.
Somebody has done it but I don't know.



-----Mensaje original-----
De: Mirek.Subrt@intax.cz [mailto:Mirek.Subrt@intax.cz]
Enviado el: Wednesday, October 18, 2000 2:35 PM
Para: tomcat-user@jakarta.apache.org
Asunto: RE: Installing Tomcat under JDK 1.1.8



Antonio,

I know that "jdk 1.2.2 is Java2 but jdk 1.1.8 is earlier version of Java",
but

at http://jakarta.apache.org/builds/tomcat/release/v3.2-beta-6/src/
at file jakarta-tomcat.tar.Z
is file Readme, where is written:

"* Download and install a version 1.1 or later Java Development Kit
implementation for your operating system platform.  ".

So can I believe to it or no?

I have to use JDK 1.1.8 because we have this versions installed at much
places and is not possible immediately to upgrade to JDK 1.3.

So, can Tomcat 3.2 beta 6 be installed under JDK 1.1.8 or not?

     Mirek Subrt

***************************************************************************




                    Antonio
                    Vazquez              To:
<tomcat-user@jakarta.apache.org>
                    <vazquezf@auc        cc:
                    land.com>            Subject:     RE: Installing Tomcat
under JDK
                                         1.1.8
                    18.10.2000
                    14:19
                    Please
                    respond to
                    tomcat-user






I think you are wrong....
jdk 1.2.2 is Java2 but jdk 1.1.8 is earlier version of Java.
but I think the best way to install it is using jdk 1.3 following the
instructions in jakarta homepage.

get lucky

-----Mensaje original-----
De: Mirek.Subrt@intax.cz [mailto:Mirek.Subrt@intax.cz]
Enviado el: Wednesday, October 18, 2000 2:03 PM
Para: tomcat-user@jakarta.apache.org
Asunto: Installing Tomcat under JDK 1.1.8


Can you help me with this problem?

I want to install Tomcat 3.2 beta 6 to unix (AIX 4.1), where I have JDK
1.1.8.

Last week I have installed Tomcat 3.2 beta 6 to my PC  (where I have JDK
1.2.2) and everything is OK.

But now - on AIX with JDK 1.1.8 - there are problems:

1) I have installed JAXP 1.1 Early Access: OK;
2) I have installed Ant (jakarta-ant): OK;
3) I have installed jakarta-servletapi: OK;
4) I have tried to install jakarta-tomcat, but

after the command "build" at directory jakarta-tomcat
compilation have started (211 classes compiled) and then the compilation
stopped with error:

[javac]
/usr/adissys/tomcat/3.2beta6/jakarta-tomcat/src/share/org/apache/tomcat/core

/ContextManager.java:335:
               Method setProperty(java.lang.String, java.lang.String) not
found in class java.lang.System.
[javac] System.setProperty("tomcat.sessionid.randomclass", randomClass);

I know that System.setProperty is not supported under JDK 1.1.8, but how is
possible, that this method is used in code, when Tomcat need not JDK 1.2.2?

Or Tomcat does need JDK 1.2.2 and under JDK 1.1.8 is impossible to install
Tomcat?
Or Tomcat can be install under JDK 1.1.8, but only Tomcat 3.1 (and not
Tomcat 3.2 beta 6)?

     Please, help me

                        Mirek Subrt






Mime
View raw message