tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chay Weei Jye" <wjc...@mailandnews.com>
Subject RE: tomcat 4.0 m1 config
Date Mon, 09 Oct 2000 00:48:55 GMT


> -----Original Message-----
> From: Craig R. McClanahan [mailto:Craig.McClanahan@eng.sun.com]
> Sent: Friday, October 06, 2000 11:59 AM
> To: tomcat-user@jakarta.apache.org
> Subject: Re: tomcat 4.0 m1 config
>
>
> Chay Weei Jye wrote:
>
> > Hi, I've downloaded & installed Tomcat 4.0 m1. The tomcat
> engine managed to
> > load and run, but when I try to http://localhost:8080/ the error such as
> > below occurs. http://localhost:8080/examples/ will list out the
> directory
> > without any problem.
> >
>
> Boy, that is a strange one.
>
> Line 534 of ApplicationHttpRequest is a call to the copyMap()
> method, which is
> defined just above it at line 411.  The only thing I can think of
> off the top of my
> head is that you are trying to run this under JDK 1.1, which is
> not going to work.

I'm using JDK1.3 on WinNT4.0 workstation.

> Have you changed the startup scripts at all?  Have you set the
> CATALINA_HOME and
> JAVA_HOME environment variables correctly?  What JDK and
Yup, both _HOMEs are set correctly, otherwise the tomcat engine wont even
startup.


> > Is there a documentation on Tomcat 4.0 configuration?
> >
>
> There is some (partially out of date) documentation at
> "src/catalina/docs/config/index.html" in the binary distribution (or
> "catalina/docs/config/index.html" in the source distribution.

Thanks, I'll look at it.




Mime
View raw message