tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul FitzPatrick" <>
Subject RE: jar's still not picked up in WEB-INF/lib
Date Mon, 09 Oct 2000 01:31:34 GMT

It could be because this works for so many people.  I t works great for me.
I have seen however, that it will not find things right if my classpath is
loaded with extra stuff when I launch tomcat.  I usually have other copies
of the jar files in my system classpath, and if I start tomcat with that
classpath I will get class not found errors.  This triggers in my mind to
stop tomcat, set classpath=. then restart tomcat and all is well.  This
might work for you too.


-----Original Message-----
From: Barry Dunne []
Sent: Sunday, October 08, 2000 10:21 PM
Subject: jar's still not picked up in WEB-INF/lib

This problem has been posted so many times for different versions of tomcat
but it is still there.

To summarise the problem, if you put a jar file into WEB-INF/lib you get a
class not found exception when you try to use one of the classes from the
jar in a servlet. However, this does not happen when you either move the jar
to /usr/local/tomcat/lib or extract the jar into WEB-INF/classes.

Neither of these workarounds are very nice, the former makes sharing a
server between multiple contexts/developers tricky and the latter makes a
mess of the classes directory.

There have been so many posts about this feature not working over time and I
have had the problem myself on linux with tomcat 3.1, 3.2 and now 4.0m1.

This is a pretty fundemental flaw as the lib is a fairly significant part of
the specifications to be able to use WEB-INF/lib.

Does anybody know why this problem has been left for so long now?


Get Your Private, Free E-mail from MSN Hotmail at

Share information about yourself, create your own public profile at

View raw message