tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amrhein, Thomas" <tamrh...@debis.com>
Subject AW: AW: redirect problems?
Date Mon, 30 Oct 2000 15:23:20 GMT
Search the archive!
I remember, this was discussed a time ago in this list (or tomcat-dev)
I found it somewhere documented or used in an example. But don't ask me
where.
It's definitively no bug.

regards

Thomas

-----Urspr√ľngliche Nachricht-----
Von: ok [mailto:aaz@webcapacity.com]
Gesendet am: Montag, 30. Oktober 2000 16:11
An: tomcat-user@jakarta.apache.org
Betreff: Re: AW: redirect problems?

yeah, I have returns, why does this do this, there is no documentation in
the
JSP spec saying i have to do returns after a redirect. Is this a bug in
tomcat?

On Mon, 30 Oct 2000, you wrote:
> Do you make a return after the sendRedirect?
> ...
> rresponse.sendRedirect("/checkout2.jsp");
> return;
> ...
> 
> Otherwise, the output of checkout2.jsp is added (and not a 'new' output).
> 
> Hint: Call sendRedirect before you make any output!!!
> 
> 
> -----Urspr√ľngliche Nachricht-----
> Von: jim [mailto:187@novagate.com]
> Gesendet am: Freitag, 27. Oktober 2000 18:41
> An: tomcat-user@jakarta.apache.org
> Betreff: redirect problems?
> 
> Hi,
> We are using Apache 1.3.12 with Tomcat 3.1 and experiencing weird
problems.
> 
> 1. checkout.jsp (FORM collecting new user info)
>    - POSTs to checkout_eng1.jsp
> 
> 2. checkout_eng1.jsp
>      - adds user from #1 and does a
response.sendRedirect("/checkout2.jsp");
> 
> 3. checkout2.jsp shows the next FORM asking for mailing address
information
> 
> 
> Weird Symptom #1
> ------------------
> On any version of Internet Explorer (never on netscape) the POST to step
#2
> above fails and up comes this IE error "cannot find server or DNS error"
> which
> leads me to beleive that the response.sendredirect() is doing something
odd,
> maybe not sending back the correct http location header or something
> 
> If you immediatly hit the browsers back button and re-submit the form, it
> then
> works with no problem and as expected. This only seems to occur the first
> time
> submitting forms to a page that re-directs after an operation.
> 
> Weird Symptom #2
> ----------------
> occasionally on Internet Explorer AND Netscape.
> User submits info from form #1 above (checkout.jsp), their information is
> added
> to the database and they are redirected to checkout2.jsp, HOWEVER what is
> shown
> on checkout2.jsp is BOTH the previous pages contents (checkout.jsp) AND
the
> expected contents of checkout2.jsp with a visible HTTP response header
> printed
> out in between checkout.jsp's contents and checkout2.jsp's contents ALL on
> visible on the URL checkout2.jsp................
> 
> Anyone have any ideas? I tried checking the bug database but it appears to
> be
> down.

Mime
View raw message