tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Skreta" <JarekSkr...@nesscomp.com>
Subject RE: JSP and Beans - still no resolution
Date Fri, 06 Oct 2000 21:02:40 GMT
Craig,

A big thank you. It worked.

However, possibly there was some problem with Tomcat 3.1. Just before I got
your reply I switched to Tomcat 3.2b and the other JSP page (the one with
property='*') started working without any changes.

Regds,

Jarek


-----Original Message-----
From: Craig R. McClanahan [mailto:Craig.McClanahan@eng.sun.com]
Sent: 06 October 2000 21:28
To: tomcat-user@jakarta.apache.org
Subject: Re: JSP and Beans - still no resolution


Jarek Skreta wrote:

> Hello,
>
> I am trying a simple application where JSP pages use Beans. The JSP in
> question uses jsp:UseBean action and then jsp:setProperty to pass some
> parameters. When I use the setProperty action with property='*' then the I
> am getting an exception when the Bean is called indicating a 'null
pointer'.
> If I set the properties explicitly (property="name" valu="value") then I
am
> getting the following exception:
>
> org.apache.jasper.JasperException: Cannot find any information on property
> 'DbDriver' in a bean of type 'DbBean'
>

According to the JavaBeans specifications, property names start with a lower
case letter, not upper case.

Thus, in your bean you would have

    public String getDbDriver() ...
    public void setDbDriver(String newDbDriver) ...

but in your JSP page you would use

    <jsp:setProperty name="beanname" property="dbDriver" value="xyz"/>

>
> This all happens when I run the application from a browser with Tomcat
(3.1)
> running. If however, I run it from within the development IDE (JDeveloper)
> everything seems to be fine.
>
> Anbody has an idea what to look for?
>
> Thanks,
>
> Jarek Skreta

Craig McClanahan

====================
See you at ApacheCon Europe <http://www.apachecon.com>!
Session VS01 (23-Oct 13h00-17h00):  Sun Technical Briefing
Session T06  (24-Oct 14h00-15h00):  Migrating Apache JServ
                                    Applications to Tomcat



Mime
View raw message