tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nacho <na...@siapi.es>
Subject RE: More information about tomcat-users.xml not being seen in Tom cat 3.2
Date Mon, 16 Oct 2000 15:42:34 GMT
Hi, Jon:

Which is the problem you have ??  

Saludos ,
Ignacio J. Ortega


> -----Mensaje original-----
> De: Jon Skeet [mailto:jon.skeet@peramon.com]
> Enviado el: lunes 16 de octubre de 2000 17:01
> Para: tomcat-user@jakarta.apache.org
> Cc: mauro.angonesi@cellnetwork.no
> Asunto: More information about tomcat-users.xml not being 
> seen in Tomcat
> 3.2
> 
> 
> Today I decided to bite the bullet and have a look at the 
> code in Tomcat-3.2b6
> to find out why I couldn't get authentication to work.
> 
> SimpleRealm.java seems to be okay - it definitely *does* read in
> tomcat-users.xml and appears to get the right information. However,
> SecurityTools.credentials doesn't seem to be doing the right 
> thing - the
> username and password don't end up in the hashtable passed in.
> 
> I haven't progressed past that level as it will require a 
> decent development
> environment in which to run tomcat, I expect. I may attempt 
> this tomorrow
> unless anyone comes up with anything interesting.
> 
> This *really* needs to be fixed before 3.2 can be released. Maybe it's
> time to get CVS set up and join the development team... if 
> anyone knows
> who's likely to be responsible for SecurityTools so I could 
> get in touch
> with them, I'd be happy to take discussion of it off this list.
> 
> Jon
> 

Mime
View raw message