tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Klein <jkl...@nightfire.com>
Subject RE: starting tomcat
Date Fri, 27 Oct 2000 17:12:29 GMT
Ciaran, for whatever its worth, the class that it is not finding is in
webserver.jar.  I see that you have that in your classpath
(%TOMCAT_HOME%\lib\webserver.jar), so it makes me think that your
TOMCAT_HOME may be pointing to the wrong place.  By the way, it is not
necessary to explicitly put each jar file into your classpath because the
startup script handles that for you.  Best of luck,
Jeff
 
 
 

-----Original Message-----
From: Ciaran Scullion [mailto:cagusn@gofree.indigo.ie]
Sent: Friday, October 27, 2000 9:56 AM
To: tomcat-user@jakarta.apache.org
Subject: starting tomcat


Hi , 
      I am a new user to tomcat on a win 98 platform ....
      I am having some problems with installing tomcat on my pc 
basically I have a tomcat_home variable set to c:\tomcat 
                                Java_home is set to C:\VisualCafe\JAVA2
 
my path is set to the following 
                 SET PATH=%PATH%;%JAVA_HOME%\BIN;C:tomcat\bin;........
 
my class path is set to the following 
 SET CLASSPATH=.;%JAVA_HOME%\lib; %TOMCAT_HOME%\classes;
%TOMCAT_HOME%\lib\jasper.jar;
%TOMCAT_HOME%\lib\servlet.jar;%TOMCAT_HOME%\lib\xml.jar;
%TOMCAT_HOME%\lib\webserver.jar;
%JAVA_HOME%\lib\tools.jar;
 
when I go in to the tomcat directory I have set up and call bin\startup or
bin\tomcat run  I get the following error 
 

Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/tomcat/startup 

does any one have any ideas ??
 
go raibh mile maith agut ( thank you in Irish)
Niambh 
 


Mime
View raw message