tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Eaton <ja...@jungawunga.com>
Subject Re: Does Tomcat 3.1 Support Apache/SSL?
Date Sat, 07 Oct 2000 02:13:22 GMT

Does anybody have an example httpsd.conf file I could look at that works 
for SSL?

Thanks.

At 06:04 PM 10/6/2000, you wrote:

>looks fine, i guess.  Is the .jsp URL not found an apache or tomcat error
>message?

Looks like an Apache error 404. I don't see any hit in the Tomcat logs for 
the url.

>I don't think I can help you because mod_jserv never suited my needs.  I
>did internal proxing, and now mod_jk is available (and my needs are a lot
>less at the moment).
>
>I would assume to look at the tomcat logs files to verify that the
>requests aren't coming to it.  Then assume it's the httpd.conf.
>
>Just another starting point.  Are .jsp's working without SSL?

Yes, when i dont specify https the JSP stuff works fine.


>HTH,
>
>Kenneth Topp
>
>
> > </Context>
> >
> > At 01:46 PM 10/6/2000, you wrote:
> >
> > >On Fri, 6 Oct 2000, Jason Eaton wrote:
> > >
> > > >
> > > > I am using the httpds.conf file included with my Apache installation.
> > > There
> > > > are <IfDefine SSL> sections in the file. Am I to wrap any Tomcat
> > > > cofigurations with <IfDefine SSL> as well?
> > >
> > >That's a safe bet.  Try towards the bottom.
> > >
> > >Good luck.
> > >
> > >Kenneth Topp
> > >
> > >
> > > >
> > > > Sorry I am new to Apache configuration.
> > > >
> > > > Thanks.
> > > >
> > > > At 01:30 PM 10/6/2000, kenneth topp wrote:
> > > >
> > > > >On Fri, 6 Oct 2000, Jason Eaton wrote:
> > > > >
> > > > > >
> > > > > > My Apache configuration supports SSL and is working but when
I
> > > access jsp
> > > > > > files or any other servlet via Tomcat/Apache/SSL I get url not

> found.
> > > > > >
> > > > > > Are my configurations messed up? Does Tomcat 3.1 support SSL?
> > > > >
> > > > >I believe there are some issues in tomcat wrt URI, making 
> assumptions of
> > > > >it being http: not https:, but I think any problem you have is 
> releated to
> > > > >your webserver configuration.
> > > > >
> > > > >Remeber, if you've done a stock mod_ssl config (for example) the ssl
> > > > >section of the httpd.conf configuration is separate from the normal
> > > > >configuration.
> > > > >
> > > > > >
> > > > > > Thanks.
> > > > > >
> > > > > > -----------------------------------------------------
> > > > > > Jason Eaton
> > > > > >
> > > > > > Jungawunga Inc.
> > > > > > http://www.jungawunga.com
> > > > > > 103B Whispering Pines Road
> > > > > > Scotts Valley, CA 95066
> > > > > > p 831.438.0475
> > > > > > m 408.858.5585
> > > > > >
> > > >
> > > >
> > > > -----------------------------------------------------
> > > > Jason Eaton
> > > >
> > > > Jungawunga Inc.
> > > > http://www.jungawunga.com
> > > > 103B Whispering Pines Road
> > > > Scotts Valley, CA 95066
> > > > p 831.438.0475
> > > > m 408.858.5585
> > > >
> >
> >
> > -----------------------------------------------------
> > Jason Eaton
> >
> > Jungawunga Inc.
> > http://www.jungawunga.com
> > 103B Whispering Pines Road
> > Scotts Valley, CA 95066
> > p 831.438.0475
> > m 408.858.5585
> >


-----------------------------------------------------
Jason Eaton

Jungawunga Inc.
http://www.jungawunga.com
103B Whispering Pines Road
Scotts Valley, CA 95066
p 831.438.0475
m 408.858.5585


Mime
View raw message