tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Corey A. Johnson" <cjohn...@cniweb.net>
Subject Re: Servlet Directory
Date Tue, 24 Oct 2000 00:42:10 GMT
Can't the servlet be invoked without an entry in the web.xml file?  via
the InvokerServlet?

Thanks again,

Cj

Craig May wrote:
> 
> Find the file named "web.xml" and add an entry for the servlet.
> 
> On Tue, 24 Oct 2000 00:14:40 Corey A. Johnson wrote:
> > Hello all,
> >
> > First, let me apologize... this is so simple... but i have been beating
> > my head against the wall for almost 20 hours straight now...
> >
> > I have successfully installed Tomcat on my Solaris... With Apache 1.3.14
> >
> > Everything seems to be working fine... JSPs work well... looking through
> > the logs... no errors...  but i can not get any servlets to work in my
> > defined servlet directory.  I must be missing something very simple.
> > When i try to invoke a servlet, the tomcat.log file shows:
> >
> > Context log: path="" Class Not Found in init
> >  java.lang.ClassNotFoundException: testAllego
> >
> >
> > In my tomcat.conf file.. i have the line:
> >
> > ApJServMount /servlet /root
> >
> > And i have this in my server.xml file:
> >
> > <Context path="" docBase="/export/home/cni/servlet" debug="0"
> > reloadable="true" >
> > </Context>
> >
> >
> > I feel like i am so close... because ay least it is "trying" to load the
> > servlet class... but tomcat can't find it..
> >
> > please help... i need some sleep...
> >
> > thanks in advance.
> >
> > Cj
> > --
> > Corey A. Johnson
> > Creative Network Innovations, Inc.
> > 1-800-264-5547 ** 1-321-259-1984

-- 
Corey A. Johnson
Creative Network Innovations, Inc.
1-800-264-5547 ** 1-321-259-1984

Mime
View raw message