tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Boni Prasanna <b...@yasutech.com>
Subject Exception @tomcat
Date Wed, 18 Oct 2000 21:40:39 GMT
Hi all,

I am using tomcat with Apache on solaris after struggling for some days I
could atleast restart the apache with tomcat.conf file.(note: i got the
mod_jserv.so file from some where else).
But now when i try to access a servlet from the browser i am getting the
following exception from Tomcat can somebody help.

HANDLER THREAD PROBLEM: java.io.IOException: Stream broken, couldn't
demarshal string :768:379
java.io.IOException: Stream broken, couldn't demarshal string :768:379
        at java.lang.Throwable.fillInStackTrace(Native Method)
        at java.lang.Throwable.fillInStackTrace(Compiled Code)
        at java.lang.Throwable.<init>(Compiled Code)
        at java.lang.Exception.<init>(Compiled Code)
        at java.io.IOException.<init>(Compiled Code)
        at
org.apache.tomcat.service.connector.Ajpv12InputStream.readString(Compiled
Code)
        at
org.apache.tomcat.service.connector.AJP12RequestAdapter.readNextRequest(Compiled
Code)
        at
org.apache.tomcat.service.connector.Ajp12ConnectionHandler.processConnection(Ajp12ConnectionHandler.java:134)

        at org.apache.tomcat.service.TcpWorkerThread.run(Compiled Code)
        at org.apache.tomcat.util.ThreadPool$ControlRunnable.run(Compiled
Code)
        at java.lang.Thread.run(Thread.java:485)

Thanks,
boni

p.s one more note: i haven't still tried from to setup things from scratch.

Boni Prasanna wrote:

> Hello all,
>
> I am sorry if this is mail is a repition. I sent it before but I wasn't
> subsribed to this list...
> I am trying to setup Tomcat with Apache on Solaris machine and I am
> having lot of problems. I checked out the archives but still no
> soultion. I had problems trying to make the mod_jserv.so file itself,
> the usual problem(lot of people seemed to have the same problem) command
>
> filed with id=167111680.. Finally i could get the file form some where
> on the net. After making appropriate changes to the Apache's httpd.conf
> file i tried restarting.. and it is giving the following error
>
> Syntax error on line 1 of
> /opt/local/home/bonip/jakarta-tomcat/conf/tomcat-apache-adj.conf:
> Can't locate API module structure `jserv_module' in file
> /usr/local/apache/libexec/mod_jserv.so: ld.so.1:
> /usr/local/apache/bin/httpd: fatal: jserv_module: can't find symbol
>
> thanks alot for your help.
> Also I am not sure whether the file mod_jserv.so I picked from net can
> work or not.. (i.e version problem?)
>
> --
> YASU (Yet Another Start Up) Technologies
> http://www.yasutech.com

--
YASU (Yet Another Start Up) Technologies
http://www.yasutech.com




Mime
View raw message