tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: 3.1 Installation Problems etc.
Date Tue, 17 Oct 2000 01:08:27 GMT
William Brogden wrote:

> "Stanley, Jim" wrote:
> >
> > Hello,
> >
> > I'm a new subscriber to the list, working with a client that's doing some
> > programming for us.  We've been a JRun shop, so we're getting used to
> > Tomcat.
> >
> > We're having installation problems with the latest version 3.1: trying to
> > start tomcat gives a "HttpConnectionHandler not found" error message.  I
> > went through the archives and there was something about using JDK1.2.2
> > instead of 1.2 - but we're already using 1.2.2 and getting this problem as
> > well.  I've checked classpaths 'till I'm blue in the face and nothing seems
> > to help.  This is on NT4, SP6;  we are testing the app on both this platform
> > and AIX.
> >
>
> I got that error due to an older JAR file being on the classpath
> and being picked up before the Tomcat Jar - took me days to find it.
>

In a Java2 environment (i.e. 1.2 or 1.3), do not forget to check your
system
extensions folder ($JAVA_HOME/jre/lib/ext) for older JAR files as well.

Craig McClanahan

====================
See you at ApacheCon Europe <http://www.apachecon.com>!
Session VS01 (23-Oct 13h00-17h00):  Sun Technical Briefing
Session T06  (24-Oct 14h00-15h00):  Migrating Apache JServ
                                    Applications to Tomcat

Mime
View raw message