tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <>
Subject Re: Tomcat 4.0 Milestone 2 - Trying to run it
Date Wed, 11 Oct 2000 01:47:06 GMT
"Lujo, Rodrigo" wrote:

> Hi all:
> I downloaded and compiled the above with JDK 1.3 on Solaris 2.6.  I did run into
> a problem
> that you may run into so I will share it.
> 1) After the "" finishes it sets up the ./build/ area where the server
> can be run from.
>    This is in JAKARTA_HOME/build.  The problem is that the "webapps" directory
> is created
>    right under JAKARTA_HOME/webapps.  However, when running from
> JAKARATA_HOME/tomcat4.0 it
>    expects that directory to be under JAKARTA_HOME/tomcat4.0/webapps.
> 2) For now I got around this by replicating the above "webapps" directory where
> it is expected.

Assume you installed the source tree into


Then the following commands should build the entire thing (assuming you have the
required environment variables set correctly):

    cd $JAKARTA_HOME/jakarta-tomcat-4.0-m2-src

This will create a build directory with the following contents:

        catalina/            The servlet container components
        jasper/               The JSP engine components
        webapps/           The web application components
        tomcat-4.0/        All of Tomcat 4.0 assembled together

To run, you need to do one of the following:

        cd $JAKARTA_HOME/build/tomcat-4.0
        ./bin/ start


        export CATALINA_HOME=$JAKARTA_HOME/build/tomcat-4.0
        $CATALINA_HOME/bin/ start

The other three build directories (catalina, jasper, and webapps) are not complete
-- they are used when you want to package the pieces individually with other

Craig McClanahan

See you at ApacheCon Europe <>!
Session VS01 (23-Oct 13h00-17h00):  Sun Technical Briefing
Session T06  (24-Oct 14h00-15h00):  Migrating Apache JServ
                                    Applications to Tomcat

View raw message