tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig R. McClanahan" <Craig.McClana...@eng.sun.com>
Subject Re: Tomcat 4 and IBMJdk1.3 for Linux
Date Wed, 04 Oct 2000 16:44:13 GMT
Anthony Marino wrote:

> "No JAXP compliant XML parser found."
>
> I have it in my classpath and am using jaxp1.0.1.
> I'm running on Redhat 7.0.
>

Are you trying to build from the source distribution?  If so, it is not good
enough to have the required libraries in your class path -- you also need to set
appropriate environment variables.  See the comments at the top of the
"build.sh" script to know which ones must be set.

For XML parsing, current nightly distributions of Tomcat 4.0 are restricted to
working with Xerces 1.2.0 only, because the new JSP stuff requires SAX2
capabilities.  This restriction will be lifted once JAXP 1.1 comes out (which
supports SAX2 as well) -- then we will be able to go back to any JAXP-compliant
parser.

Craig McClanahan

====================
See you at ApacheCon Europe <http://www.apachecon.com>!
Session VS01 (23-Oct 13h00-17h00):  Sun Technical Briefing
Session T06  (24-Oct 14h00-15h00):  Migrating Apache JServ
                                    Applications to Tomcat



Mime
View raw message