tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kitching Simon <Simon.Kitch...@orange.ch>
Subject RE: Tomcat doesn't find classes
Date Thu, 05 Oct 2000 16:17:58 GMT


> -----Original Message-----
> From:	Bondi: Runar Oli Bjarnason [SMTP:rob@bi.bondi.is]
> Sent:	Thursday, October 05, 2000 4:47 PM
> To:	tomcat-user@jakarta.apache.org
> Subject:	Tomcat doesn't find classes
> 
> 
> 
> Hello.
> 
> When I set up a webapp under Tomcat, it doesn't seem to find any classes
> or
> .properties files under [nameOfApp]/WEB-INF/classes. It also does not find
> jar files under [nameOfApp]/WEB-INF/lib. If I put them under
> [Tomcat_Home]/classes and [Tomcat_Home]/lib, it finds them no problem and
> everything works fine. However, this creates class-name conflicts and it's
> a huge mess. How can I make Tomcat look for classes in the WEB-INF
> directories for each webapp?
> 
> Best regards,
> 
> Runar
> 
	[Kitching Simon]  

	Strange, you're doing exactly the right things.

	If you put classes under the [nameOfApp]/WEB-INF/classes
	directory, they are automatically visible to tomcat.
	Same for .jar (*not* .zip) files in [nameOfApp]/WEB-INF/lib.

	You don't need to set up anything special to have this work.
	All you need is to put the webapp in TOMCAT_HOME/webapps,
	or to set the baseDir in the context, as described in the manual.
	If you can see .html files in your webapp, then you've got that
right...

	The problem must be something trivial - perhaps the files
	don't have read permission for the user tomcat is running
	as, or something like that???

	Good luck,

	Simon


Mime
View raw message