tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ed Stafford <>
Subject Problems with Tomcat/Jserv on Solaris
Date Fri, 06 Oct 2000 21:19:38 GMT
I've been trying to install Tomcat+Apache on a Sun
Solaris 7 system today.  Here's what I've gotten:

Using Tomcat 3.1-Stable:
 * Tomcat compiles without error
 * Jserv module fails to build.  I've performed:
  apxs -o -c *.c

and it returns with an error:
apxs:Break: Command failed with rc=-256

I did notice that the last line lacks a linker or
anthing. Here's the output of the last few lines:
gcc -DSOLARIS2=270 -DUSE_EXPAT -I../lib/expat-lite
-DNO_DL_NEEDED  -I/usr/local/apache/include  -c
gcc -DSOLARIS2=270 -DUSE_EXPAT -I../lib/expat-lite
-DNO_DL_NEEDED  -I/usr/local/apache/include  -c
  -o mod_jserv.o jserv_wrapper_win.o
jserv_wrapper_unix.o jserv_wrapper.o jserv_watchdog.o
jserv_utils.o jserv_status.o jserv_protocols.o
jserv_mmap.o jserv_image.o jserv_balance.o
jserv_ajpv12.o jserv_ajpv11.o autochange.o 

As you can see, after mod_jserv.c compiles, and it
goes to compile it all into a library, it doesn't list
a linker.  On an x86 Linux machine, the exact same
thing works find with a 'gcc -shared ' before the -o. 
I tried building it by hand by putting 'gcc ' before
the -o, but it complains about symbol errors, and
looks like it's trying to link to some apache library
which doesn't exist (or I don't know where the library

I REALLY need help on this guys.  I know it's not the
latest and greatest build, but it's for a production
environment.  Here's the description of the installed
software on this system:

Solaris 7 Server
bison 1.2.8
Sun JDK 1.3


Ed Stafford

Do You Yahoo!?
Yahoo! Photos - 35mm Quality Prints, Now Get 15 Free!

View raw message