tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Bateman" <jo...@cyberworldgroup.com>
Subject RE: Error running ./startup.sh
Date Tue, 24 Oct 2000 18:54:04 GMT
RE: Error running ./startup.shI thank you all for your support and input
over the last few trying days.

This is, by far, the most interactive (and interesting) list I've
participated in.

Thanks.
  -----Original Message-----
  From: John Bateman [mailto:johnb@cyberworldgroup.com]
  Sent: Tuesday, October 24, 2000 2:04 PM
  To: Tomcat-User (E-mail)
  Subject: Error running ./startup.sh



  Hi

  I'm getting an error when I try and run tomcat in stand alone mode. The
logs
  don'e show anything wrong.

  Error:

  [root@opus bin]# ./startup.sh
  Using classpath:

.:/usr/local/tomcat/lib/ant.jar:/usr/local/tomcat/lib/jasper.jar:/usr/local/

tomcat/lib/servlet.jar:/usr/local/tomcat/lib/test:/usr/local/tomcat/lib/webs

erver.jar:/usr/local/tomcat/lib/xml.jar:/usr/local/java/lib/tools.jar:.:./:/

lib/classes.zip:/classes:/lib/dt.jar:/lib/tools.jar:/jre/lib/rt.jar:/usr/loc
  al/lib/jconn2.jar
  [root@opus bin]# Starting tomcat. Check logs/tomcat.log for error messages
  FATAL:java.net.BindException: Address already in use
  java.net.BindException: Address already in use
          at java.net.PlainSocketImpl.socketBind(Native Method)
          at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:386)
          at java.net.ServerSocket.<init>(ServerSocket.java:169)
          at java.net.ServerSocket.<init>(ServerSocket.java:120)
          at

org.apache.tomcat.net.DefaultServerSocketFactory.createSocket(DefaultServerS
  ocketFactory.java:97)
          at

org.apache.tomcat.service.SimpleTcpEndpoint.startEndpoint(SimpleTcpEndpoint.
  java:186)
          at

org.apache.tomcat.service.SimpleTcpConnector.start(SimpleTcpConnector.java:1
  42)
          at
  org.apache.tomcat.core.ContextManager.start(ContextManager.java:253)
          at org.apache.tomcat.startup.Tomcat.execute(Tomcat.java:157)
          at org.apache.tomcat.startup.Tomcat.main(Tomcat.java:163)

  I have all my environment variables set (and verified!) but I keep getting
  this error.

  I'll be happy to post any additional information needed, but I don't want
to
  post everything if it's just going to take up the net's precious
bandwidth.

  Thanks alot.




  -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
  John Bateman
  Cyber World Group Inc.


Mime
View raw message