tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Goodwin <SGood...@e-xpedient.com>
Subject RE: JSPs work but not servlets --- still not working
Date Wed, 13 Sep 2000 19:15:40 GMT
David,
 
I'm experiencing the same problem at the moment.(a 404 response page)  If
you find an answer please list on this group or email me.
 
We have Tomcat v3.1 running on a Solaris box.  I've got a custom directory
working now (with servlets working) running stand alone mode and off port 80
(Tomcat's HTTP), but I want to use the WEB-INF off the ROOT directory under
Tomcat.  The SnoopServlet works but I can't get any custom servlets to run
there yet.  What file(s) need to be updated?  server.xml, tomcat.conf, ...?
 
Help is much appreciated.
 
Steve Goodwin
sgoodwin@e-xpedient.com
 
 
 
-----Original Message-----
From: david [mailto:ymidt@yahoo.com]
Sent: Wednesday, September 13, 2000 2:48 PM
To: tomcat-user@jakarta.apache.org
Subject: RE: JSPs work but not servlets --- still not working
 
Still not working and going crazy...
There was a typo in my last append, all servlet classes ARE
under webapps/tasp/web-inf/classes are are not in packages (yet).
 
I have tried with and without a <context> in the server.xml
and with various changes in my /web-inf/web.xml file, but no luck,
JSPs work, but I still get a 404 error for servlets!
 
I have tried to increase the logging levels in server.xml and for
the context manager, but don't get any helpful output!
 
Help is much appreciated!!!
 
thanks 
-- David
 
------------------------ previous append
----------------------------------------------------------------------------
---
 

Thanks for the help attempts.
I can get .jsp files to run, but not servlets!!!!  Help!  This Servlet ran
fine under JServe...
 
I have my stuff in /webapps/tasp  with the appropriate dir structure
I have a web.xml file under /webapps/tasp/web-inf:
<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE web-app
    PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.2//EN"
    " http://java.sun.com/j2ee/dtds/web-app_2.2.dtd
<http://java.sun.com/j2ee/dtds/web-app_2.2.dtd> ">
<web-app>
     <servlet>
      <servlet-name>ServletTest</servlet-name>
        <servlet-class>ServletTest</servlet-class>
     <servlet-mapping>
         <servlet-name>ServletTest</servlet-name>
         <url-pattern>ServletTest</url-pattern>
     </servlet-mapping>
     </servlet>
</web-app>
my servlet ServletTest.java and ServletTest.class are under
/webapps/tasp/web-inf/classes
 
the .jsp that runs is just under /webapps/tasp
 
the server.xml has an added context:
 
        <Context path="/tasp" docBase="webapps/tasp" debug="9"
reloadable="true" > 
        </Context>
 
the tomcat.log file is saying:
Context log: path="/tasp" In error handler 404 null / R( /tasp +  +
/ServletTest)
Context log: path="/tasp" Error: Calling servlet Wrapper(tomcat.errorPage
S:org.apache.tomcat.servlets.DefaultErrorPage)
Any ideas what I'm missing to serve my servlets???  I have tried with "demo"
servlets with no difference...
 
 
Also, am I correct in understanding then that when Tomcat runs alone, it
only needss the server.xml and various web.xml files
or does it still use the tomcat.properties and zone.properties files????
Are all the properties files for working with Apache only??
 
TIA,
-- david
  _____  


Mime
View raw message