tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From greg <em...@gregorybittar.com>
Subject Re: forbidden: you don't have access
Date Mon, 25 Sep 2000 21:38:39 GMT
Thanks Sean, but I do not think that solves my problem.  I've noticed that
when I access Apache (checking out /var/log/access.log), that whenever I do
not add the '/' slash to the end of a directory name, then Apache seemingly
puts one in there for me and re-executes the page.  In any case, I have tested
my server with localhost:8080/myWebApp/  and it hasn't changed things.  In
fact, I am having more problems with access through my domain name than with
the localhost.  Maybe I'm just all burned out.  Thanks for trying to help
though.  I appreciate the genuine interest.

Sean Schofield wrote:

> This sort of sounds like a problem I was having.  Basically I couldn't get
> to various apps (including the examples) one through Apache-Tomcat but I
> could get them fine through Tomcat standalone (port 8080) but didn't work
> when I was running Apache and Tomcat together and hitting port 80.
>
> I accidentally stumbled upon the solution when I was trying the links from
> the Jakarta welcome page (on 8080) and then just highlighted the ':8080' in
> the URL and deleted it.  It worked!  The difference was that the URL had an
> extra '/' at the end.  Try 'localhost:8080/myWebApp/' with an extra '/' at
> the end.
>
> Let me know if it worked.
>
> - schof
>
> At 04:42 PM 9/25/00 -0400, you wrote:
> >I am trying to reinstall Tomcat, in particular the beta 4, ver 3.2.
> >Whoever decided that not having basic security implemented and working
> >correctly in 3.1 made a mistake, imo.  The advice has been to try using
> >one of the betas, but this isn't a way that people can build their own
> >production systems using Tomcat.  Seeing that something so basic as user
> >authentication was not working, I think the prudent thing to do would
> >have been to go back and re-release 3.1 with this vital feature
> >working.  Indeed, for many people, there is no version 3.1 if there is
> >no user authentication in 3.1.
> >
> >Biting the bullet, I have spent the last several days trying to get the
> >beta to work on my machine, not knowing what to expect next.  I am
> >having several problems.  The shutdown script is not working.  But the
> >real misfortune so far is that I am having difficulty even accessing my
> >application.   I try variously with 8080 and 8007 ports, and I have
> >tried re-installing Tomcat twice, and even copied back my ORIGINAL
> >Tomcat 3.1 installation, which had been working fine, and now I get this
> >behaviour:
> >
> >localhost:8080/myWebApp -> works when Tomcat is set to 8080, doesn't
> >when Tomcat is set to 8007.
> >mydomain.com/myWebApp -> "403 Forbidden: You don't have access to
> >myWebApp on this server
> >
> >I've checked all the file and directory rights I can think of.  Could
> >Tomcat have permanently unsettled my Apache environment?  The weird
> >thing is that my first installation of the beta was going along
> >more-or-less smoothly until I added a security-constraint to myWebApp's
> >web.xml file.  Ever since then, I have been contending with 'forbidden'
> >errors.  Versions of Tomcat have come and gone on my server, as I
> >attempt to regain a stable environment, and yet the song remains the
> >same.
> >
> >Apologies to the Tomcat folks for my rant.  Up until now I have been
> >hunky dory, but I have some production stuff I have to get out the door.


Mime
View raw message