tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Doyle <mdo...@iceinteractive.com.au>
Subject problems with mod_jserv
Date Tue, 05 Sep 2000 01:31:59 GMT
Hi All

	And just another thing, I have the TomCat Minimalistic User's Guide
(which is what I have been following), and it has been moved.  There is
something new out there called mod_js, but the documentation is kinda
minimal, and I can't even find the mod_js stuff!    

   I was wondering if anyone here is an Apache/Tomcat/mod_jserv legend?

        The problem is this.  We are trying to compile mod_jserv into
Apachie,
so we can run multiple dev environments on our server.

        The actual command to do this is:

        apxs -c -o mod_jserv.so *.c

        This uses the apxs script that apache creates when it is
compiled. 
This can be found at /usr/local/apache/bin

        Problem 1:
        When you run the above command, it all seems to go find until
you reach
a line:

gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED 
-I/opt/local/apache/include  -c mod_jserv.c 
  -o mod_jserv.so mod_jserv.o jserv_wrapper_win.o jserv_wrapper_unix.o
jserv_wra 
pper.o jserv_watchdog.o jserv_utils.o jserv_status.o jserv_protocols.o
jserv_mma 
p.o jserv_image.o jserv_balance.o jserv_ajpv12.o jserv_ajpv11.o
autochange.o 
apxs:Break: Command failed with rc=16711680 

        As you can see, there is a "  -0 mod_jserv...." etc.  Looks like
something is missing.

        When you check the apxs script, you see that some variables are
missing, such as:

my $CFG_TARGET        = q(httpd);            # substituted via
Makefile.tmpl 
my $CFG_CC            = q(gcc);                # substituted via
Makefile.tmpl
my $CFG_CFLAGS        = q( -DSOLARIS2=260 -DUSE_EXPAT
-I../lib/expat-lite -DNO_DL_NEEDED `../apaci`);            # substitut
ed via Makefile.tmpl
my $CFG_CFLAGS_SHLIB  = q();      # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = q();          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(); # substituted via Makefile.tmpl 
my $CFG_LIBS_SHLIB    = q();        # substituted via Makefile.tmpl 
my $CFG_PREFIX        = q(/opt/local/apache-1.3.12);            #
substituted via APACI install
my $CFG_SBINDIR       = q(/opt/local/apache-1.3.12/bin);           #
substituted via APACI install
my $CFG_INCLUDEDIR    = q(/opt/local/apache-1.3.12/include);        #
substituted via APACI install
my $CFG_LIBEXECDIR    = q(/opt/local/apache-1.3.12/libexec);        #
substituted via APACI install
my $CFG_SYSCONFDIR    = q(/opt/local/apache-1.3.12/conf);        #
substituted via APACI install

See anything missing?  Such as the linker?

Anyway, I continued and changed the $CFG_LD_SHLIB  to be "ld".

        This is when I get to problem 2:

When I run the script, my environment settings are as follows:



LD_LIBRARY_PATH=/usr/lib:/usr/local/lib:/usr/share/lib:/usr/openwin/lib:/usr/dt/lib:/usr/ccs/lib:/usr/oracle/app/product/8.0.5/lib:.



PATH=/usr/bin:/usr/ccs/bin:/usr/oracle/app/product/8.0.5/bin:/usr/local/bin:/usr/local/bin:/usr/local/apache/bin

I now get the error:


bash-2.02# apxs -c -o mod_jserv.so *.c
gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
-I/opt/local/
apache-1.3.12/include  -c autochange.c
gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
-I/opt/local/
apache-1.3.12/include  -c jserv_ajpv11.c

<<Other stuff deleted>>

gcc -DSOLARIS2=260 -DUSE_EXPAT -I../lib/expat-lite -DNO_DL_NEEDED
-I/opt/local/
apache-1.3.12/include  -c mod_jserv.c
ld  -o mod_jserv.so mod_jserv.o jserv_wrapper_win.o jserv_wrapper_unix.o
jserv_w
rapper.o jserv_watchdog.o jserv_utils.o jserv_status.o jserv_protocols.o
jserv_m
map.o jserv_image.o jserv_balance.o jserv_ajpv12.o jserv_ajpv11.o
autochange.o
Undefined                       first referenced
 symbol                             in file
socket                              jserv_watchdog.o
ap_table_unset                      mod_jserv.o
ap_pstrdup                          mod_jserv.o
ap_MD5Update                        jserv_ajpv12.o
ap_os_escape_path                   jserv_ajpv12.o

**About 200 more file names....

connect                             jserv_watchdog.o
ld: fatal: Symbol referencing errors. No output written to mod_jserv.so
apxs:Break: Command failed with rc=65536


So you can see...a few problems.

I'm worried at the various variables are not set up problerly in apxs,
and that the libraries are not found.

Does anyone have any experiance with this?

What should my various variables be?  Both environmental and in apxs?

Suggestions? Comments?

Thanks
        Mike
Mime
View raw message