tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Braswell, Sy " <KK2...@dfa.state.ny.us>
Subject load-on-startup
Date Thu, 14 Sep 2000 13:19:36 GMT
i have a connection pool servlet that i would like loaded when tomcat
starts. i have tried using the following syntax in the web.xml file:

    <servlet>
         <servlet-nameConnectionPool</servlet-name>
         <servlet-class>berm.search.ConnectionPool</servlet-class>
         <load-on-startup>1</load-on-startup>
    </servlet>

1) im not sure if the ConnectionPool.class is suppose to be on the path
/usr/local/tomcat/classes/berm/search/ConnectionPool.class

or 

/usr/local/tomcat/webapps/bermPatSearch/WEB-INF/classes/berm/search/Connecti
onPool.class

if i do not put it in the path 
   /usr/local/tomcat/classes/berm/search/ConnectionPool.class
i get the error:
cannot load servlet name: ConnectionPool
cannot load servlet name: ConnectionPool
cannot load servlet name: ConnectionPool
cannot load servlet name: ConnectionPool
cannot load servlet name: ConnectionPool
cannot load servlet name: ConnectionPool

if i do put it on the path:
/usr/local/tomcat/classes/berm/search/ConnectionPool.class
i do not get the above error
but it does not load either.

2) which xml file does is go in?
/usr/local/tomcat/conf/web.xml
or
/usr/local/tomcat/webapps/bermPatSearch/WEB-INF/web.xml

i have tried all combinations of above with no luck...
any ideas?
is there another parameter that needs to be set?




Mime
View raw message